This is the mail archive of the guile@cygnus.com mailing list for the guile project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: Scheme style auto-resizing hashtable (fwd)





wrote:...
>Thus I assume, if you name you hash-tables dictionaries, some day someone
will >come up with an additional tree-dictionary data type. In this case I
think a >cleaner solution is to have a hash-table data type and an
ordered-tree data type >and then let the users select the implementation if
they need _some_ kind of >dictionary.

I think you're making a lot of sense here. The trouble is some people
*want*
a hash table, and should say so explicitely. Some people want a dictionary,
and don't care much how it is implemented.

Ideally, the people who don't care, should be writing code that reflects
the
fact that they don't care. i.e. It should use dynamically bound versions
of most of the manipulation functions so that if one day they start
fine-tuning performance by changing implementations, all their code will
still work.

The bottom line is - I think a hash table should be called hash-table. I
think
the word "dictionary" should be reserved for some future OO class library,
which will probably use hash-table as an implementation.

All IMHO of course :-) Let's build a proper object system!!