This is the mail archive of the mailing list for the glibc project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

iostream header missing?

Hi all.

Here is a simple c program I tried compiling and it failed:

	#include <iostream>
	main() {
	  cout << "Hello, world!" << endl;

The output I got is follows:
	t.cpp:1: iostream: No such file or directory

The version of gcc I am using is:

	Reading specs from /usr/lib/gcc-lib/i486-linux/
	gcc version

on Linux S.u.S.E 5.2:

	Linux aardvark 2.0.34 #67 Thu Jun 18 17:04:10 MEST 1998 i686 unknown

I was just wondering if anyone on the list has an idea of solving
my problem. It all started when we tried installing octave-2.1.30.

We obtained the following output:

	 make[2]: Entering directory `/home/j/root/octave-2.1.30/liboctave'
	 c++ -c  -I. -I.. -I../liboctave -I../src -I../libcruft/misc  -
	 I../glob -I../glob -DHAVE_CONFIG_H -mieee-fp -fno-rtti -fno-implicit-
	 templates -g -O2 -Wall -o Bounds.o iostream: No such file or directory
	 In file included from
	 Bounds.h:30: iostream: No such file or directory
	 make[2]: *** [Bounds.o] Error 1

That is why I had to try out the c program given above.

Any form of help will be greatly appreciated. Thanks.

Gerald Marewo  Macintosh Software Hints:
MACSOFT anarchie-201.hqx fetch-303.hqx finger-150.hqx ncsa-telnet-27b4.hqx
MACSOFT stuffit-expander-401.bin

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]