This is the mail archive of the glibc-bugs@sourceware.org mailing list for the glibc project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

[Bug build/17950] Build fails with -msse


https://sourceware.org/bugzilla/show_bug.cgi?id=17950

Carlos O'Donell <carlos at redhat dot com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |WAITING

--- Comment #1 from Carlos O'Donell <carlos at redhat dot com> ---
(In reply to Vyacheslav Barinov from comment #0)
> Created attachment 8115 [details]
> Patch proposal
> 
> Build both with -msse and -Werror causes build error:
> 
>   cc1: all warnings being treated as errors
>   dl-runtime.c:1:0: error: SSE instruction set disabled, using 387
> arithmetics [-Werror]

Adding -Wno-error is not the correct fix.

You need to determine why this warning happens. It's valid to use -msse and
-mno-sse together, they do not generate a warning.

It seems like you're compiling with -msse for a target that doesn't support SSE
and thus getting a warning.

What are you configure options? What does your config.log say?

-- 
You are receiving this mail because:
You are on the CC list for the bug.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]