This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH 1/4] Class-fy regcache


On 04/28/2017 03:26 PM, Yao Qi wrote:
> @@ -320,84 +283,90 @@ make_cleanup_regcache_invalidate (struct regcache *regcache, int regnum)
>  struct gdbarch *
>  get_regcache_arch (const struct regcache *regcache)
>  {
> -  return regcache->descr->gdbarch;
> +  return regcache->get_gdbarch ();
>  }

This "get_" oddly stayed behind.  I think you should rename
it to "arch()".  (That's what we called the equivalent 
method in struct gdb_disassembler.)

Otherwise looks good to me.

Thanks,
Pedro Alves


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]