This is the mail archive of the mailing list for the GDB project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH 00/11] C++/MinGW patches

On 11/03/2015 11:14 AM, Qian Hong wrote:
> On Tue, Nov 3, 2015 at 6:46 PM, Qian Hong <> wrote:
>> actual result:
>> gdb exit with error message: "This application has requested the
>> Runtime to terminate it in an unusual way. Please contact the
>> application's support team for more information." when debugging a
>> simple hello world program. "
> Update:
> I also test it on Wine, for your convenient, if you don't have Windows
> nearby to test, maybe Wine is an option.

I've actually tried Wine multiple times before over the years.  I've managed
to run gdbserver under Wine (in the past, haven't tried recently), and connect
to it with a GNU/Linux-hosted cross debugger (--host=linux --target=mingw),
but gdb running under Wine has never worked for me.  The problem for
me is that input does not work.

> I tested with Wine Staging 1.7.53, which provides prebuilt binaries to
> mainstream Linux distributions [1].

Using Wine Staging 1.7.51 I get:

$ ./gdb.exe
fixme:winediag:start_process Wine Staging 1.7.51 is a testing version containing experimental patches.
fixme:winediag:start_process Please report bugs at (instead of
Z:\home\pedro\gdb\mygit\cxx-convertion\build-c-mingw\gdb\gdb.exe: warning: cannot automatically find executable file or library to read symbols.
Use "file" or "dll" command to load executable/libraries directly.
GNU gdb (GDB)
Copyright (C) 2015 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-w64-mingw32".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
Find the GDB manual and other documentation resources online at:
For help, type "help".
Type "apropos word" to search for commands related to "word".
(gdb) fixme:ole:RemUnknown_QueryInterface No interface for iid {00000019-0000-0000-c000-000000000046}
p 1

(gdb) bt


Those brank lines are me pressing enter.  Seems like the newline/input never
reaches gdb.  ctrl-c does work, as can be seen by the "Quit"s.

This is on Fedora 20.

Pedro Alves

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]