This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH 05/18] poison "private"


On 10/09/2013 06:17 PM, Ondrej Oprala wrote:
>    /* Private data used by the target vector implementation.  */
> -  struct private_thread_info *private;
> +  struct private_thread_info *private_data;
>  
>    /* Function that is called to free PRIVATE.  If this is NULL, then
>       xfree will be called on PRIVATE.  */

These PRIVATE references should also be updated.  The field that
comment is describing is:

  /* Function that is called to free PRIVATE.  If this is NULL, then
     xfree will be called on PRIVATE.  */
  void (*private_dtor) (struct private_thread_info *);

I think it should be renamed accordingly too.


BTW, I think it'd be much clearer if we renamed away all this
'private' wording, like, say:

  struct private_thread_info -> struct target_thread_info

and:

  struct target_thread_info *target_data;
  void (*target_data_dtor) (struct target_thread_info *);

-- 
Pedro Alves


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]