This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH] Rename local variable 'oneproc' to 'force_to_step'.


On 01/17/2013 01:17 PM, Yao Qi wrote:

> diff --git a/gdb/infrun.c b/gdb/infrun.c
> index c0fbf0b..b576e10 100644
> --- a/gdb/infrun.c
> +++ b/gdb/infrun.c
> @@ -2139,7 +2139,8 @@ proceed (CORE_ADDR addr, enum gdb_signal siggnal, int step)
>    struct thread_info *tp;
>    CORE_ADDR pc;
>    struct address_space *aspace;
> -  int oneproc = 0;
> +  /* GDB may force the inferior to step due to various reasons.  */
> +  int force_to_step = 0;

"force to step" doesn't sound natural to my
non-native years (mainly the "to").  I'd suggest "int force_step"
or even "GDB may need to step" (int need_step).  But that's
minor.  Any way is fine.

-- 
Pedro Alves


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]