This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [rfc] skip_ilp32_tests / skip_lp64_tests predicates (was: Re: support biarch gcore?)


H.J. Lu wrote:

> > This syntax is strange. There are
> >
> > --
> > if { ![istarget i?86-*-*] && ![istarget x86_64-*-* ] } {
> >  verbose "Skipping x86 AVX tests."
> >  return
> > }
> > ...
> > if [istarget i?86-*-*] {
> >  set nr_regs 8
> > } else {
> >  set nr_regs 16
> > }
> > ...
> >
> > I am looking for something like is_ilp32/is_lp64.

Hmm, I was simply trying to keep the naming scheme in line with
the pre-existing skip_..._tests routines.  However, I guess you're
right if the test needs to be used for other decisions than
simply skipping a test, a different name would be better.

> 2010-07-09  Ulrich Weigand  <uweigand@de.ibm.com>
> 	    H.J. Lu  <hongjiu.lu@intel.com>
> 
> 	* lib/gdb.exp (is_ilp32_target): New.
> 	(is_lp64_target): Likewise.
> 
> 	* gdb.arch/amd64-byte.exp: Use is_lp64_target to check 64bit
> 	target.
> 	* gdb.arch/amd64-disp-step.exp: Likewise.
> 	* gdb.arch/amd64-dword.exp: Likewise.
> 	* gdb.arch/amd64-i386-address.exp: Likewise.
> 	* gdb.arch/amd64-word.exp: Likewise.
> 
> 	* gdb.arch/i386-avx.exp: Use is_ilp32_target to check for 32bit
> 	target.
> 	* gdb.arch/i386-bp_permanent.exp: Likewise.
> 	* gdb.arch/i386-byte.exp: Likewise.
> 	* gdb.arch/i386-disp-step.exp: Likewise.
> 	* gdb.arch/i386-gnu-cfi.exp: Likewise.
> 	* gdb.arch/i386-prologue.exp: Likewise.
> 	* gdb.arch/i386-size-overlap.exp: Likewise.
> 	* gdb.arch/i386-size.exp: Likewise.
> 	* gdb.arch/i386-sse.exp: Likewise.
> 	* gdb.arch/i386-unwind.exp: Likewise.
> 	* gdb.arch/i386-word.exp: Likewise.
> 
> 	* gdb.arch/ppc64-atomic-inst.exp: Use is_lp64_target to execute
> 	test only when building 64-bit executables.  Do not hard-code
> 	-m64 option.

This is OK.

Thanks,
Ulrich

-- 
  Dr. Ulrich Weigand
  GNU Toolchain for Linux on System z and Cell BE
  Ulrich.Weigand@de.ibm.com


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]