This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [RFA] Reverse Debugging, 4/5


> Erm, yeah, I started to say "I'm open to it", but hey, I just want to
> get my patch in!  Surely it will be easy enough to change this to a
> generic setter later?

I don't think I'm the type to let best be the enemy of good, but
in this case, changing the function name wouldn't delay your patch
all that much. So I would insist in that case that you make the
change now rather than later - that way, there's no risk of
forgetting. Or are you concerned that choosing the name might
turn into a long thread?

This being said, I would be totally open to not using the function
at all, and setting b->silent directly.  This is a well-documented
standalone flag and I'm personally fine with accessing it directly.
Ideally, I would love for GDB to only use opaque types, but we can
always create the accessor routines if/when we decide to make the
breakpoint structure opaque (opinions welcome).

-- 
Joel


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]