This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [RFA] Reverse Debugging, 4/5


>>>>> "Joel" == Joel Brobecker <brobecker@adacore.com> writes:

Michael> +void
Michael> +breakpoint_silence (struct breakpoint *b)
Michael> +{
Michael> +  /* Silence the breakpoint.  */
Michael> +  b->silent = 1;

Joel> Minor nit: This name brings little meaning when I see it being called.
Joel> Can we change it to "make_breakpoint_silent"?  That way, the comment
Joel> in the body becomes useless and can be removed.

The Python breakpoint wrapper directly sets or clears b->silent.
Perhaps we could make this a generic setter in anticipation of that
patch?

Tom


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]