gdb-patches archive
subject index for September, 2008

This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.

Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

[autodeps] gnu-nat, autogenerated files

[commit, spu] Do not error out if backchain is unreadable

[commit, spu] Do not use generic_push_dummy_code

[commit, spu] Update all $sp slots for inferior calls

[commit/Ada] better handling for unchecked union types

[commit/Ada] Delete dead ADA_RETAIN_DOTS macro

[commit/Ada] Do not search the minimal symbol during symbol lookup

[commit/Ada] Fix bug when doing ptype of a tagged-type variable

[commit/Ada] Improve dereferencing of integers

[commit/Ada] Improve name lookup performance

[commit/Ada] Special handling for predefined exceptions...

[commit/Ada] Wrong value of packed array on big endian targets

[commit/testsuite/ada] accept "boolean" as the type description for boolean types

[commit/testsuite/ada] Make print tests a little more robust...

[commit/testsuite/Ada] Update Makefile.in:EXECUTABLES list

[commit] Disable displaced stepping on AIX

[commit] Fix "set debug arch 1" crash

[commit] Fix struct and struct-pointer casts

[commit] Fix testcase for SPU (Re: [RFA/testsuite] stack check)

[commit] Fix up some races and regexps in MI tests

[commit] remove extra verbose -log calls in testcases

[commit] Respect gdb,no_hardware_watchpoints in all test cases

[commit] unbreak gdbserver on uclinux

[commit] Update my email address

Re: [commited] Detect bad debug info

[Fwd: Re: [patch] Re: Accessing tls variables across files causes a bug]

[ob] fix breakpoint always-inserted fallout

[ob] fix inf-ttrace.c

[ob] Fix mips64/-mabi=32 gdbserver build

[ob] Fix missing parenthesis

[ob] gnu-nat.c, don't error out on target_pid_to_exec_file

[ob] gnu-nat.c, push target before adding threads

[PATCH 0/4] 'catch syscall' feature

[PATCH 1/4] 'catch syscall' feature -- Architecture-independent part

[PATCH 2/4] catch syscall' feature -- Architecture-dependent part

[PATCH 3/4] catch syscall' feature -- Documentation part

[PATCH 4/4] catch syscall' feature -- Testcase part

[patch, rfc] Re: target_find_description question

[PATCH/RFC] auxv entries

[Patch] Add mips-linux hardware watchpoint support.

[Patch] Fix 'incomplete type' warning in dummy_frame.h

[patch] Fix a crash on NULL event_thread

[PATCH] Fix argument-passing error in linux-nat.c

[patch] Fix crash on reading gcc HEAD Fortran module

[PATCH] Fix dwarf register column to gdb register mapping

Re: [patch] Fix for failing gdb.base/mips_pro.exp under gcc-4.3.1

[PATCH] Fix hppa_linux_sigtramp_frame_unwind_cache

Re: [patch] Fix Linux attach to signalled/stopped processes

Re: [Patch] Fix memory corruption when using multiple hardware watchpoints.

[Patch] Fix memory corruption when using multiple hardware watchpoints.

[PATCH] Fix reading floating point registers from core files on hppa-linux

Re: [patch] Fix SIGSEGV in gdb when printing ctor of non-virtual class

[patch] Fix SIGSEGV in gdb when printing ctor of non-virtual class

[PATCH] Get rid of generic_push_dummy_code

Re: [PATCH] Handle absence of DT_DEBUG while debugging ld.so

[PATCH] Handle newlines in args

[Patch] Improve path lookup of absolute source file

[patch] Re: GDB aborts on missing command args. Which way to fix?

[patch] Set register even when no frame exists

[patch] static_kind -> bit0, bit1 [Re: [gdb] Fortran dynamic arrays]

Re: [patch] static_kind -> bit0, bit1 [Re: [gdb] Fortran dynamic arrays]

Re: [patch] step over permanent breakpoint

[PATCH] Topo in gdb comment

[Patch] Use resume instead of target_resume when stepping over watchpoint.

[ping] Displaced stepping with wrong entry point address

Re: [remote protocol][doc] PATCH: document remote protocol extensions for multi-process debugging

[reverse RFA] break-reverse.exp testcase

[reverse RFA] Change the name of record

[reverse RFA] no singlestep-over-BP in reverse

[reverse RFA] record_wait return TARGET_WAITKIND_NO_HISTORY

[reverse RFC] Fix some bugs

[reverse RFC] test for restored machine state

[RFA 00/08] multi-process support

[RFA 01/08] multi-process support: struct inferior

Re: [RFA 01/08] multi-process support: struct inferior (alternate manual content)

Re: [RFA 02/08] multi-process support: all targets manage inferior list

[RFA 02/08] multi-process support: all targets manage inferior list

Re: [RFA 03/08] multi-process support: remote multi-process ?extensions

Re: [RFA 03/08] multi-process support: remote multi-process extensions

Re: [RFA 03/08] multi-process support: remote multi-process extensions

[RFA 03/08] multi-process support: remote multi-process extensions

Re: [RFA 04/08] multi-process support: Make stop_soon a per-inferior property

[RFA 04/08] multi-process support: Make stop_soon a per-inferior property

Re: [RFA 05/08] multi-process support: Make attach_flag a per-inferior property

[RFA 05/08] multi-process support: Make attach_flag a per-inferior property

Re: [RFA 06/08] multi-process support: when quitting, kill or detach all inferiors

[RFA 06/08] multi-process support: when quitting, kill or detach all inferiors

[RFA 07/08] multi-process support: fix follow-exec part 1

[RFA 08/08] multi-process support: fix follow-exec part 2

[RFA/Ada] Implement Ada tasking support

[RFA/Ada] Implement Ada tasking support (take 2)

Re: [RFA/commit/dwarf] Create partial symbols for nested subprograms

[RFA/commit/dwarf] Create partial symbols for nested subprograms

[RFA/doco/Ada] Document special case for catchpoints on standard exceptions

Re: [RFA/DWARF2] Handle nested subprograms in CU pc bound calculation

[RFA/DWARF2] Handle nested subprograms in CU pc bound calculation

Re: [RFA/powerpc] Add handling for stack-check sequences in prologue

[RFA/powerpc] Add handling for stack-check sequences in prologue

[RFA/RFC] libdecnumber/gstdint.h is back :-(

[RFA/testsuite] stack check

[RFA] dcache.c cleanup

[RFA] dwarf2 die dumper

[RFA] dwarf2read.c:comp_unit_head cleanup

[RFA] gdb-freeplay

[RFA] gdb_continue_to_breakpoint

Re: [RFA] Kill ptrace_ops_hack

[RFA] misc dwarf2 cleanup

[RFA] rename paddr_[du] to p{,u}longest

[RFA] reorganize comp_unit_head for better packing

[RFA] small size reduction to struct die_info

Re: [RFC: 0/9] No context-switching

Re: [RFC: 3/9] Make stop_bpstat per-thread in all-stop, and don't context-switch

Re: [rfc] [0/8] Eliminate current_gdbarch from *-tdep.c

[rfc] [00/18] Cell multi-arch debugger

[rfc] [01/18] Cell multi-arch: Per-thread architecture infrastructure

[rfc] [02/18] Cell multi-arch: Per-frame architecture infrastructure

[rfc] [03/18] Cell multi-arch: Save/restore current_gdbarch

[rfc] [04/18] Cell multi-arch: Support TARGET_OBJECT_SPU object type

[rfc] [05/18] Cell multi-arch: Non-file-backed shared library BFD infrastructure

[rfc] [06/18] Cell multi-arch: Temporary breakpoint insertion failures

[rfc] [07/18] Cell multi-arch: Preserve bp location info across objfile relocation

[rfc] [08/18] Cell multi-arch: Some address vs. pointer fixes

[rfc] [09/18] Cell multi-arch: Pass GDBARCH to gdbarch_pointer_to_address

[rfc] [10/18] Cell multi-arch: Core files for standalone SPU executables

[rfc] [11/18] Cell multi-arch: Target description <compatible> infrastructure

[rfc] [12/18] Cell multi-arch: Implement tdesc <compatible> feature for Cell

[rfc] [13/18] Cell multi-arch: Core of the Cell debugger

[rfc] [14/18] Cell multi-arch: gdbserver support for the Cell debugger

[rfc] [15/18] Cell multi-arch: Per-frame architecture for the Cell debugger

[rfc] [16/18] Cell multi-arch: Add "set spu stop-on-load" command

[rfc] [17/18] Cell multi-arch: Support __ea address space qualifier

[rfc] [18/18] Cell multi-arch: Automatically flush software-managed cache

Re: [rfc] add ppc testcase to test fpscr

Re: [RFC] Allow overloaded general functions

Re: [rfc] Displaced stepping with wrong entry point address

[rfc] Do not inherit to_open and to_close

Re: [RFC] doc for gdb-freeplay

[RFC] dwarf2read.c die_info -> cu backpointer

Re: [rfc] Eliminate implicit current_gdbarch use in dwarf2_read_address

[rfc] expose gdb values to python

Re: [rfc] Fix removing breakpoint from shared library race

Re: [RFC] PowerPC prologue unwinder / epilogue detection improvements

Re: [RFC] Remove addr, endaddr, offset from obj_section

Re: [rfc] Support overlays with relocated sections

Re: [rfc] Use proper extraction routine for C++ pointer-to-method types

Re: [rfc] Use proper extraction routine for C++ pointer-to-method types

[rfc] Use proper extraction routine for C++ pointer-to-method types

Re: [rfc][00/37] Eliminate builtin_type_ macros

Re: [rfc][03/37] Eliminate builtin_type_ macros: Extract bitstring subscript handling

Re: [rfc][05/37] Eliminate builtin_type_ macros: Replace LA_BOOL_TYPE macro

Re: [rfc][07/37] Eliminate builtin_type_ macros: Use expression arch for size_t type

Re: [rfc][08/37] Eliminate builtin_type_ macros: Make pointer arithmetic explicit

Re: [rfc][08/37] Eliminate builtin_type_ macros: Make pointer arithmetic explicit

[rfc][1/2] add suport for 64-bit fpscr in powerpc linux native

Re: [rfc][10/37] Eliminate builtin_type_ macros: Use expression arch for argument promotion

Re: [rfc][13/37] Eliminate builtin_type_ macros: Update EVAL_SKIP dummy return type

Re: [rfc][15/37] Eliminate builtin_type_ macros: Dereferencing of integer types

Re: [rfc][16/37] Eliminate builtin_type_ macros: Ada fixed/double conversions

Re: [rfc][19/37] Eliminate builtin_type_ macros: Ada range type handling

Re: [rfc][2/2] add suport for 64-bit fpscr in gdbserver for powerpc linux

[rfc][2/2] add suport for 64-bit fpscr in gdbserver for powerpc linux

Re: [rfc][21/37] Eliminate builtin_type_ macros: Platform-neutral builtin_type_void

Re: [rfc][21/37] Eliminate builtin_type_ macros: Platform-neutral builtin_type_void

Re: [rfc][21/37] Eliminate builtin_type_ macros: Platform-neutral builtin_type_void

Re: [rfc][23/37] Eliminate builtin_type_ macros: Platform-neutral types for internal variables

Re: [rfc][23/37] Eliminate builtin_type_ macros: Platform-neutral types for internal variables

Re: [rfc][24/37] Eliminate builtin_type_ macros: Platform-neutral generic integers

Re: [rfc][27/37] Eliminate builtin_type_ macros: Update C++ ABI handling

Re: [rfc][28/37] Eliminate builtin_type_ macros: Update infcall.c routines

Re: [rfc][28/37] Eliminate builtin_type_ macros: Update infcall.c routines

Re: [rfc][31/37] Eliminate builtin_type_ macros: Inferior call argument types

Re: Accessor macro wrappers removal [Re: [patch] static_kind -> bit0, bit1]

Accessor macro wrappers removal [Re: [patch] static_kind -> bit0, bit1]

Re: add file I/O support when debugging an embedded target via jtag

Cell multi-arch: combined patch

GDB aborts on missing command args. Which way to fix?

Re: gdb sources

gnu-nat.c, compile it without -Werror

How to submit a LARGE patch

Issue with gdbserver --multi / remote-extended on Windows XP

Make procfs.c build warning free

Re: non-stop linux native, unbreak -exec-interrupt --all, add an MI test

Re: non-stop linux native, unbreak -exec-interrupt --all, add an MI test

Re: patch to send telnet BREAK for remote-over-tcp

Patch to update gdbint.texinfo [00/05]

Patch to update gdbint.texinfo [01/05]

Patch to update gdbint.texinfo [02/05]

Patch to update gdbint.texinfo [03/05]

Patch to update gdbint.texinfo [04/05]

Patch to update gdbint.texinfo [05/05]

PATCH: Extend gdb remote protocol for AVX

Pedro Alves as Global Maintainer

Re: ping [Fwd: [RFC] User choice for multiply-defined symbols]

Ping/RFC: Add mips-linux hardware watchpoint support.

Ping: Fix memory corruption when using multiple hardware watchpoints.

PR gdb/856

RE: replace typedef_print with a language method

Revised patch to update gdbint.texinfo [00/04]

Revised patch to update gdbint.texinfo [01/04]

Revised patch to update gdbint.texinfo [02/04]

Revised patch to update gdbint.texinfo [03/04]

Revised patch to update gdbint.texinfo [04/04]

RFA: change K&R to ISO

RFA: consistently use symbol accessors

RFA: fix minor memory leak in symfile.c

RFA: fix stray use of printf_filtered

Re: RFA: implement all missing macro expansion features

RFA: minor objfile cleanup

RFA: minor test suite fix

Re: RFA: PR 2484: completion of macro names

RFA: remove METHODS_DOMAIN

RFA: replace typedef_print with a language method

RFA: shrink struct minimal_symbol

target_find_description question

unbreak execution commands in hook-stop

Updating libtool


Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

Mail converted by MHonArc 2.6.3