This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [RFC 2/5] Frame unwinding using struct value


As usual, thank you for the comments.

On Tue, Apr 01, 2008 at 06:27:58AM +0300, Eli Zaretskii wrote:
> Thanks, this part is approved, but I have some comments:
> 
> > +@node Stack Frames
> > +@chapter Stack Frames
> > +
> > +@cindex frame
> > +@cindex call stack frame
> > +A frame is a construct that @value{GDBN} uses to keep track of calling
> > +and called functions.
> > +
> > +@cindex frame, unwind
> 
> It is not useful to have several index entries that begin with the
> same string and point to the same page.  So I suggest to replace the
> last one with "@cindex unwind frame".

Sure; I was just moving these, but let's take the opportunity to
improve it further.

> > +Developers wishing to learn more about unwinders, are encouraged to
> > +read the @sc{dwarf} specification.
> 
> How about a pointer to the DWARF Spec here?

Sounds good.  I expect it will stay on dwarfstd.org for a while; it's
had several homes in the last few years.

> > +is a sentinel frame, then @code{get_frame_type (@var{f}) ==
> > +SENTINEL_FRAME}.
> 
> I would use @equiv{} here, of even @expansion{}, instead of a literal
> "==".

Interesting, I didn't know about those.  I like the block
of C code -- if you want to check whether something is a sentinel
frame in GDB, you type get_frame_type (f) == SENTINEL_FRAME -- but
@equiv will do nicely too so I'll use that.

> > +@section Selecting an Unwinder
> 
> Is it a good idea to have a section without a node?

That's how most of the gdbint manual is currently arranged - one node
per chapter, except for a few more substantial ones.  I can move the
new sections into nodes if you think that's better.

> Please add an @findex entry for each function you mention.

Done.

> I think we should say "lvalue" here, not "lval".

Fixed.

> > +Same as @code{frame_unwind_got_constant}, excep that the value is a target
>                                              ^^^^^
> A typo.

Also fixed.

I'll repost the final patch in a little while.

-- 
Daniel Jacobowitz
CodeSourcery


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]