This is the mail archive of the gdb-patches@sources.redhat.com mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Ping: [patch] general updates and improvements to QNX NTO support


Hmm....I think the diff hard to read. I haven't gotten rid of struct nto_target_ops in nto-tdep.h. All I did is move the comments into the definition of the structure from outside with the defines.

I also changed the macro defines so that I can assign and test. ie.

old:
define nto_regset_fill(regset, data) (*current_nto_target.nto_regset_fill) (regset, data)


new:
#define nto_regset_fill (current_nto_target.nto_regset_fill)

That way I can easily switch targets in code.

I am defining current_nto_target in nto-tdep.h as being extern but I don't declare it there. Is having a global verboten? I has assumed it was okay since we have many precedents like inferior_ptid and current_target and such.

cheers,

Kris

Mark Kettenis wrote:

  Date: Fri, 03 Dec 2004 11:12:14 -0500
  From: Kris Warkentin <kewarken@qnx.com>

Weekly ping. It's really not that bad....I ran gdb_indent.sh on it....it's only affecting QNX specific stuff....I tested it on Windows, Linux and Neutrino...

It is bad.  It defines variables in a header file.  That's
unacceptable.  What's your motivation for getting rid of `struct
nto_target_ops' in the first place?  Seems like a step in the wrong
direction to me.

Please fix this, then resubmit.  I promise to look at it in a timely
fashion if you do.

Mark




Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]