gdb-patches archive
subject index for February, 2004

This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.

Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

-file-list-exec-source-file

-file-list-exec-source-files

-symbol-list-lines doco update

[6.1] Mention existance of 6.1 branch

[commit/frame] Allow the legacy frame

[commit/hppa] Enable 32-bit push_dummy_call and return_value

[commit/hppa] Enable 32-bit unwinder, fix NPC

[commit/java] Work around java/1565 in jmisc.exp

[commit/mips] frame conversion, pass #1

[commit/mips] Group deprecated unwind code

[commit/mips] Remove frame fallout

[commit/pa] Fix 32-bit push dummy call

[commit/pa] Re-order gdbarch_init

[commit/tui] Clean up ARI probs

[commit/tui] Cleanup TUI includes a little

[commit/tui] Cleanup tui-data.h, first pass

[commit/tui] Cleanup tui-data.h, second pass

[commit/tui] Cleanup tui-source.h

[commit/tui] Cleanup tui-win.h

[commit/tui] Cleanup tui-windata.h

[commit/tui] Cleanup tui-wingeneral.h

[commit/tui] Cleanup tui-winsource.h

[commit/tui] Cleanup tui.h

[commit/tui] convert remaining globals to gnu-case

[commit/tui] gnu-case the .c files

[commit] "Tidy" dependencies

[commit] Add an opaque declaration

[commit] Add HPPA push_dummy_call; keep disabled

[commit] Assume START_INFERIOR_TRAPS_EXPECTED defined

[commit] Change #if0 to if(0) in hpux

[commit] Default to new frame code

[commit] Eliminate deprecated_register_convertible_not

[commit] Fix hpux warnings

[commit] Fix readline include dependencies

[commit] Handle duplicates when generating init.c

[commit] HP/UX unwinder, don't enable

[commit] Implement 32-bit HP/PA push_dummy_call

[commit] Implement HP/PA return_value; don't enable

[commit] Implement mips_unwind_pc

[commit] Import config.guess & config.sub 2004-02-16

[commit] Mention 6.1 in various README and doco files

[commit] More Makefile simplification

[commit] More Makefile.in fixes

[commit] Move some more hppa deck chairs

[commit] Re-arange hpux deck chairs

[commit] re-fix init.c duplicate elimination

[commit] Require legacy_frame_p when "seriously old code"

[commit] separate hpux struct-return & infcall

[commit] Simplify subdir config

[commit] tweak frame debug output

[commit] Update Makefile dependencies

[commit] Update texinfo.tex to 2004-02-19

[commit] Use add_setshow_auto_boolean_cmd, not var_auto_boolean

[commit] When push_dummy_call, ignore FIX_CALL_DUMMY

[commit] zap some inside_entry_file

[COMMITTED DOC PATCH] remote protocol support for TARGET_OBJECT_AUXV

[COMMITTED PATCH] docs for info auxv

[COMMITTED PATCH] typos

[committed] Import newer install-sh, mkinstalldirs

Re: [cplus] Add an entry point for cp-names

[hppa] GDB doesn't build with tui

[intercu] A bit of duplicated work

[intercu] Add a cache

[intercu] Add dependence tracking to the CU cache

[intercu] Add less to our hash table

[intercu] Allocate abbrevs on an obstack

[intercu] Copy names from the psymbol

[intercu] Don't crash on unnamed enums

[intercu] Don't process types multiple times

[intercu] Fix lazy tree building

[intercu] Handle DW_AT_specification for partial DIEs

[intercu] Handle DW_FORM_indirect too

[intercu] Handle references in full DIEs

[intercu] Handle simple DIEs pre-emptively

[intercu] Improve hash table size estimate

[intercu] Initial tree-building

[intercu] Make some more data per-objfile

[intercu] Memory management fixes for last patch

[intercu] Memory management update

[intercu] Merge comment fixes from posted patch

[intercu] Mostly warning tweaks

[intercu] Move abbrev table out of comp_unit_head

[intercu] Move the DIE hash table into dwarf2_cu

[intercu] Optimize DIE skipping

[intercu] Partial symbol table inter-cu support

[intercu] Reduce mindless data copying

[intercu] Save and restore type info

[intercu] Shrink partial_die_info

[intercu] Union fix for C++

[intercu] Update DW_AT_specification handling

[intercu] Use a hash table for DIEs after all

[intercu] Use an obstack for the partial DIEs

[intercu] Use cleanups properly

[intercu] Working inter-cu references for full symbols

[ob] Add missing #include "gdb_string.h"

[ob] Another unused function

[ob] delete config/vax/tm-vax.h

[ob] Don't clobber inferior_ptid in read_pc_pid

[ob] Fix remaining CONFIG_LIB_OBS

[ob] Fix thread-specific.exp

[ob] mips-linux build fix

[ob] Random cleanups

[ob] Remove an unused function from thread-db.c

[ob] Remove initializations of memset'd structure

[ob] Use bfd_set_cacheable

[ob] user-regs.c build fix for arm-linux

[obish/HPUX] Disable bigcore

Re: [obish] -Wunused-function warnings

[obish] Delete dead deprecated functions

[obish] Delete SIGTRAMP_PC_OFFSET

[obish] More redundant (START_INFERIOR_TRAPS_EXPECTED macros

[obish] Use gdb_test_multiple and consistent PASS / FAIL in corefile.exp

[obish] Zap #ifdef SYSCALL_TRAP code in m68k

[PATCH/commit] cleanup some fields in objfile.

[patch/doco] gdb.texinfo: fix thinko in auxv, @{GDBN}

[patch/gdbserver] Add a debugging output to linux-arm-low.c

[patch/gdbserver] Avoid a nasty little problem in the remote protocol T packet

[patch/gdbserver] Be slightly more verbose

[patch/gdbserver] Handle early interrupts

[patch/gdbserver] Update current inferior when using vCont

[PATCH/ob] typo in nodebug.exp

[PATCH/ob] unify objfile obstacks (1/4)

[PATCH/ob] unify objfile obstacks (3/4)

[PATCH/ob] unify objfile obstacks(2/4)

[patch/obvious] sh-tdep.c: Add missing commas

[patch/rfa] Delete jmisc2.exp

[patch/rfa] Test java's "break main"

[patch/rfc,6.1?] Use right frame ID in step_over_function

[patch/rfc/mi] Remove mi1 tests

Re: [patch/rfc; rfa:doco] Add -Wunused-function to -Werror list

[patch/rfc; rfa:doco] Add -Wunused-function to -Werror list

Re: [patch/rfc;rfa:doco] Add -Wunused-function to -Werror list

[patch/rfc] "tui"

[patch/rfc] Add implicit .l.c and .y.c rules

[patch/rfc] Add internal-error recovery to gdb_expect_list

[patch/rfc] Build TUI when curses

[patch/rfc] Delete prologue_frameless_p

[patch/rfc] Delete target "none"

[patch/rfc] Deprecate FRAMELESS_FUNCTION_INVOCATION

[patch/rfc] Deprecate register_gdbarch_swap

[patch/rfc] Don't escape '\e'

[patch/rfc] Fix inside entry func call

[patch/rfc] Give frame_args_skip a default

[patch/rfc] mention C++ support in NEWS

[patch/rfc] Move alpha START_INFERIOR_TRAPS_EXPECTED to nm-osf.h

[patch/rfc] Move skip_prologue_using_sal to symtab.c

Re: [PATCH/RFC] Per-architecture DWARF CFI register state initialization

[PATCH/RFC] Per-architecture DWARF CFI register state initialization hooks

Re: [PATCH/RFC] Per-architecture DWARF CFI register state initializationhooks

Re: [patch/rfc] Skip .cvsfiles in src-release; Was: [rfa/binutils] distclean .cvsignore?

[patch/rfc] Skip .cvsfiles in src-release; Was: [rfa/binutils] distclean.cvsignore?

Re: [patch/rfc] Skip .cvsfiles in src-release; Was: [rfa/binutils]distclean .cvsignore?

[patch/rfc] Test struct0

[patch/rfc] The off again, on again, PC == 0 in get_prev_frame

[patch/rfc] v2 bigcore.exp

[patch/rfc] Zap remaining Wunused-function

[patch/testsuite/cp] inherit.exp: accept both "ctor()" and "ctor(void)"

[patch/testsuite/cp] inherit.exp: accept gcc 3.2-7-rh -gstabs+

[patch/testsuite/cp] remove 'please email bug-gdb@prep.ai.mit.edu'

[patch/testsuite/cp] virtfunc.exp: accept both "ctor()" and "ctor(void)"

[patch/testsuite] pending.exp: fix gdb_test "...\n"

[patch/testsuite] Wait for gdbserver output

[PATCH] Add amd64*.c to ALLDEPFILES in Makefile.in

[PATCH] Add comments to linespec.c

[PATCH] Add OpenBSD/alpha support

[PATCH] Add preliminary OpenBSD/amd64 support

[PATCH] Add StackGhost native support for OpenBSD/sparc

[PATCH] add-symbol-file-from-memory command

[PATCH] Adjust open flags in gdb.base/fileio.c

[PATCH] Adjust OpenBSD/amd64 signal trampoline recognition

[PATCH] Allow breakpoints to generate SIGSEGV

Re: [PATCH] auxv support

[patch] Avoid ERROR in thread-specific.exp

[PATCH] Avoid use of current_gdbarch in amd64-nat.c

[PATCH] Change xfail to kfail in call-ar-st.exp

[PATCH] Cleanup i386-nat.c

[PATCH] Common ILP32 and LP64 link map offsets

[PATCH] Don't include <malloc.h>

[PATCH] Don't run bigcore.exp on *BSD

[PATCH] Don't set MH_CFLAGS for OpenBSD/i386 host

[patch] DWARF-2 enumerators typo

[PATCH] Enable DWARF-2 frames on S/390

[PATCH] Enable gdb.stabs/wierd.exp on *BSD

[PATCH] Expose register state from dwarf2-frame.c

[PATCH] Final s/x86_64/amd64g

[PATCH] Finalize SPARC StackGhost support; add TARGET_OBJECT_WCOOKIE

[patch] Fix a core dump when stdin closes

[patch] Fix chng-syms.exp for remote stubs

[PATCH] Fix comment in amd64-tdep.c

[PATCH] Fix compilation of tui/tui.c

[PATCH] Fix compiler warning in proc-api.c

[PATCH] Fix illogical variable names in sparc-tdep.c

[PATCH] Fix Linux x86-64-to-i386 register mapping

[PATCH] Fix OpenBSD/i386 a.out shared library support

[PATCH] Fix OpenBSD/i386 sigtramp recognition

[PATCH] Fix PR backtrace/1545

[PATCH] Fix PR build/1549

[patch] Gdbserver error codes

[PATCH] Handle empty DWARF CFI return address column

[patch] Import a basic-sim.exp patch from dejagnu

[patch] Initialize padding in gdb.base/relocate.c

[PATCH] Introduce amd64_collect_fxsave

[PATCH] Introduce i387_collect_fxsave

[PATCH] m32r-*-gdb outputs wrong dissassemble codes for 0x*2 addresses.

[PATCH] Make functions static in i386nbsd-tdep.c and i386obsd-tdep.c

[PATCH] move entry_point stuff to objfiles.c

[PATCH] NEWS entry for removal of i[3456]86-*-bsd*

[PATCH] OpenBSD/amd64 core dump support

[patch] Problem with gdb_breakpoint change for pending breakpoints

[PATCH] Rationalize i386 & AMD64 *BSD configurations

[PATCH] Re: [rfa/amd64] Zero fill 32-bit registers

[PATCH] remote protocol support for TARGET_OBJECT_AUXV

[PATCH] Remove duplicate function call in m68hc11-tdep.c

[PATCH] Remove old 386BSD support

[PATCH] remove PROGRESS macros

[PATCH] remove REQUEST_QUIT macro use

[PATCH] Rename FreeBSD/amd64 sigtramp location variables

[PATCH] Repair OpenBSD/amd64

[patch] Report the correct thread-specific breakpoint

Re: [PATCH] Resubmitted - Fix gdb.arch/{gdb1291.c,gdb1431.c}

[PATCH] s/x86_64/amd64/ for Linux native

[PATCH] s/x86_64/amd64/ for Linux target

[PATCH] some new sh-sim tests

[PATCH] StackGhost support for signal handlers on OpenBSD/sparc

[patch] Test for thread-specific breakpoint bug

[PATCH] The big x86_^& amd64 move

[PATCH] Tweak comments in tm-x86-64linux.h

[PATCH] unify initialization of obstack

[PATCH] unify objfile obstacks (4/4)

[PATCH] Update config/djgpp/fnchange.lst

[PATCH] Update config/djgpp/fnchange.lst (Take 2)

[PATCH] Watchpoint enhancement for S/390

[PATCH]: Fix breakpoint.c for non SOLIB-ADD platforms

[PATCH]: remove warning message in printcmd.c

[RFA (revised)] sh-sim, expand the opcode table

[rfa/amd64] Zero fill 32-bit registers

[rfa/arm] Handle bx and blx

[rfa/binutils] distclean .cvsignore?

[RFA/doco] add obstacks to gdbint.texi

[RFA/doco] Format c++ name

[rfa/doco] Update to fdl 1.2

[RFA/dwarf-2] Add support for included files

[RFA/dwarf-2] Fix for the null record problem

[RFA/dwarf] Allocate abbrevs from a new obstack

[RFA/dwarf] Don't process types multiple times

[RFA/dwarf] Optimize partial DIE reading for uninteresting DIEs

[rfa/mi testsuite] Handle missing inferior I/O for mi-syn-frame.exp

[rfa/mips] Shared library trampoline support for mips-linux

[RFA/PROBLEMS] Document the QUIT problem

[rfa/remote] Reread symbols on 'target remote'

[RFA/RFC] (hppa/tui) Fix build failure due to missing wborder

Re: [RFA/RFC] QUIT doesn't seem to be working !?

[rfa/symbol readers] Clean up setting symbols' names

Re: [rfa/symtab] Move find_pc_section call to lookup_minimal_symbol_by_pc

Re: [rfa/symtab] Move find_pc_section call to lookup_minimal_symbol_by_pc

Re: [rfa/symtab] Move find_pc_section call tolookup_minimal_symbol_by_pc

Re: [rfa/symtab] Move find_pc_section callto lookup_minimal_symbol_by_pc

[rfa/testsuite/lib] get_compiler_info: two improvements

[RFA/testsuite] Add testcase for included files

Re: [RFA/testsuite] backtrace past pthread_cond_wait()

[rfa/testsuite] gdb1250.exp: make 'break abort' work with new pending breakpoints

[RFA/tui] (solaris) Fix tui.c build failure

[rfa:amd64] Fetch 32-bit thread area

[rfa:doco] mention gdbarch_obstack_zalloc in per-module data

[rfa:doco] Zap mi1 reference

[rfa] Add SYMBOL_SET_LINKAGE_NAME

[rfa] C++ testsuite fix for unsigned char

[rfa] cris-tdep.c: Frame unwind and dummy call fixes

[RFA] Detect non-timeout fails in chng-syms.exp

[RFA] Eliminate useless test of variable before overwriting it in sh-tdep.c

[RFA] Fix a crash in coffread.c (Was: GDB 6.1 branch 2004-02-26-gmt)

[rfa] fix for PR c++/1553

[RFA] Fix gdb.base/gdb1250.exp to work when abort() is in a shared library

[RFA] Fix incorrect use of "until" command in gdb.arch/gdb1431

[RFA] Fix PR tdep/1291, SH prologue scanning bug

[RFA] Fix several problems with the gdb.arch/gdb1291.exp test

[RFA] Fix testsuite gdb.base/bang.exp to work with remote targets

[RFA] Fix TUI build failure on AiX 4.3.2

Re: [rfa] function overloading and namespaces

[RFA] Handle sh-elf-gcc scheduling code into a prologue when no debug info present

[RFA] Handle unsupported "-shared" in gdb1555.exp test

Re: [RFA] inside_entry_func() related changes

[rfa] qSymbol in remote_wait

[rfa] Remove add_psymbol_with_dem_name_to_list and uses

Re: [RFA] Repost ARM frame patches

[RFA] sh-sim loose ends

[RFA] sh-sim: free up some room in jump_table

[RFA] sh-sim: thislock/prevlock tweak

[RFA] sh-tdep.*: Rename DSP bank registers

[RFA] sh-tdep.c: Define only the minimal register set in sh_generic_register_name

[RFA] sh-tdep.c: Fix erroneus register skipping in sh_print_registers_info

[RFA] sh-tdep.c: New patch solving gdb1291.exp (was Re: [RFA] Fix PR tdep/1291, SH prologue scanning bug)

[RFA] sh-tdep.c: optimize and rename virtual register conversion functions

[RFA] sh-tdep.c: optimize fv_reg_base_num and dr_reg_base_num

Re: [rfa] teach linespec about nested classes

[RFA] use frame IDs to detect function calls while stepping

[RFA] Use runto_main in testsuite for consistency

[rfa] Use SYMBOL_SET_NAMES in hpread

Re: [RFA]: Fix objc/1236 - printing non-debuggable symbols

[RFA]: Patch for ia64-tdep.c to cross-compile

Re: [RFA]: Patch for regression with huge integer

[RFA]: patch to ia64.inc in gdb.asm testsuite

[RFA]: pending breakpoint cosmetic change

Re: [RFA]: pending breakpoint support [1/3]

Re: [RFA]: pending breakpoint support [2/3]

Re: [RFA]: pending breakpoint support [3/3]

[RFC/RFA] (testsuite/Ada) Add gdb_compile_ada

Re: [RFC/RFA] find_pc_sect_psymtab(): symbol table not always complete

[RFC] Framework for selectively omitting individual testsuite tests or directories for local use only

Re: [RFC] Gdb does not honor -tty option with builtin simulators(includes possible patch)

[RFC]: new set breakpoint pending and show breakpoint pending commands

Re: [RFC]: new set breakpoint pending and show breakpoint pendingcommands

Re: [RFC]: remove inconsistency in printcmd.c: print_scalar_formatted

Add FR450 support to the FR-V port

Address Incorrect

Avoid obstack_free in cp-namespace.c

Re: complete command doesn't work for files...

Re: CRIS port; frame cleanup crash

Daniel, the branch is NOT unfrozen

exec_file_hook_count data-type

information

make execute_control_command conform to docs

Re: make inferior calls work on ia64 even when syscall is pending

more robust get_compiler_info

No branch

Patch to fix simulation of the FR405 scutss instruction

Patch to remove rst* instructions from frv.cpu

PATCH: mention correct GCC version

PATCH: S390 modernization patch 1/6

PATCH: S390 modernization patch 2/6

PATCH: S390 modernization patch 3/6

PATCH: S390 modernization patch 4/6

PATCH: S390 modernization patch 5/6

PATCH: S390 modernization patch 6/6

Problems with dejagnu and c++ tests...

Remote target (CRIS) DejaGNU config scripts

Re: RFA (?) Annotate Level 3 patch

Re: RFA: Don't use obsavestring in dwarf2read

Re: RFA: handle zero-length types in value_from_register

Re: RFC: Fix basicclass.exp for sim targets

RFC: Handle thread hopping for the singlestep breakpoint

Re: RFC: selected frame in read_var_value

SH4 simulator timings (Was: Re: rtlopt loop unroller question (fwd))

snapshot barfing ...

Spotting a NetBSD/PPC sigtramp frame?

texinfo.tex?

Re: threads/1576: Linux 2.6 thread status path in /proc has changed

Time for a HP/PA hackathon?

Re: TUI build failure and SEG fault

Various minor FR-V fixes

Write-after-approval access


Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

Mail converted by MHonArc 2.6.3