This is the mail archive of the gdb-cvs@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

gdb and binutils branch master updated. 283f7163ecb9e36c817ded1c7306650d1dc44c11


This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "gdb and binutils".

The branch, master has been updated
       via  283f7163ecb9e36c817ded1c7306650d1dc44c11 (commit)
       via  29453a14557af65ed7a0867722b0145bb9f0e0c2 (commit)
       via  0fb14d8ffde0940e0b55d529c50a5d424b763b13 (commit)
      from  22825df749cf79e849f6df35a6d3d0ae4e5a277e (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=283f7163ecb9e36c817ded1c7306650d1dc44c11

commit 283f7163ecb9e36c817ded1c7306650d1dc44c11
Author: Yao Qi <yao@codesourcery.com>
Date:   Fri Nov 1 12:28:54 2013 +0800

    Use target_read_code in disassemble.
    
    This patch teaches "disassembly" use code cache mechanism to read
    target code.
    
    gdb:
    
    2013-11-24  Yao Qi  <yao@codesourcery.com>
    
    	* disasm.c (dis_asm_read_memory): Call target_read_code
    	instead of target_read_memory.

https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=29453a14557af65ed7a0867722b0145bb9f0e0c2

commit 29453a14557af65ed7a0867722b0145bb9f0e0c2
Author: Yao Qi <yao@codesourcery.com>
Date:   Fri Nov 1 12:26:10 2013 +0800

    set/show code-cache
    
    Similar to stack cache, in this patch, we add
    TARGET_OBJECT_CODE_MEMORY to read code from target and add a new
    option "set code-cache on|off" to optimize code accesses by
    using the target memory cache.
    
    In V4:
     - Remove "without affecting correctness" from NEWS and doc.
     - Replace "ON" with "on" in doc.
     - "access" -> "accesses".
    
    In V3:
     - Rename functions and variables.
     - Update command help, doc and NEWS entry.
     - Invalidate cache on option transitions, to align with
       the behaviour of "stack-cache".  Since cache invalidation is
       transparent to users, users don't know option "stack-cache"
       transitions cause code cache invalidation.
    
    V2 was reviewed by Doug.  There are some changes in V3, so I post it
    here.
    
    gdb:
    
    2013-11-24  Yao Qi  <yao@codesourcery.com>
    
    	* NEWS: Add note on new "set code-cache" option.
    	* target-dcache.c (code_cache_enabled_1): New variable.
    	(code_cache_enabled): New variable.
    	(show_code_cache, set_code_cache): New function.
    	(code_cache_enabled_p): New function.
    	(_initialize_target_dcache): Register command.
    	* target-dcache.h (code_cache_enabled_p): Declare.
    	* target.c (memory_xfer_partial_1):Handle
    	TARGET_OBJECT_CODE_MEMORY and code_cache_enabled.
    	(target_read_code): New function.
    	* target.h (enum target_object) <TARGET_OBJECT_CODE_MEMORY>:
    	New.
    	(target_read_code): Declare.
    
    gdb/doc:
    
    2013-11-24  Yao Qi  <yao@codesourcery.com>
    
    	* gdb.texinfo (Caching Remote Data): Document new
    	"set/show stack-cache" option.

https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=0fb14d8ffde0940e0b55d529c50a5d424b763b13

commit 0fb14d8ffde0940e0b55d529c50a5d424b763b13
Author: Yao Qi <yao@codesourcery.com>
Date:   Wed Nov 20 16:21:47 2013 +0800

    Renaming in target-dcache.c
    
    Hi,
    This patch does some renamings on "stack-cache" related functions and
    variables.
    
    In the review to "code cache" series v2, we have some discussions on the
    name of predicate function 'stack_cache_enabled', and have some options,
    
     1 keep it unchanged, as it is already a predicate clearly,
     2 rename it to stack_cache_enabled_p,
     3 rename it to enable_stack_cache_p,
    
    I choose #2, because 'stack_cache_enabled' is a predicate, but
    it's better to add "_p" suffix to stress this.  There are some other
    similar patterns used in GDB source, such as unop_user_defined_p
    and agent_loaded_p.
    
    Then, I have to rename variable stack_cache_enabled_p to something
    else.  The option is "stack-cache", so I'd like to name the variable
    associated with this command as "stack_cache".  Similarly, the commands
    associated with this command should be renamed to "set_stack_cache"
    and "show_stack_cache" respectively.
    
    gdb:
    
    2013-11-24  Yao Qi  <yao@codesourcery.com>
    
    	* target-dcache.c (stack_cache_enabled_p_1): Rename to ...
    	(stack_cache_enabled_1): ... this.  New variable.
    	(stack_cache_enabled_p): Rename to ...
    	(stack_cache_enabled): ... this.  New variable.
    	(set_stack_cache_enabled_p): Rename to ...
    	(set_stack_cache): ... this.  Update caller.
    	(show_stack_cache_enabled_p): Rename to ...
    	(show_stack_cache): ... this.  Update caller.
    	(stack_cache_enabled): Rename to ...
    	(stack_cache_enabled_p): ... this.  Update caller.
    	(_initialize_target_dcache): Replace "data cache" with
    	"target memory cache".
    	* target-dcache.h (stack_cache_enabled): Remove declaration.
    	(stack_cache_enabled_p): Add declaration.

-----------------------------------------------------------------------

Summary of changes:
 gdb/ChangeLog       |   38 ++++++++++++++++++++++++
 gdb/NEWS            |    5 +++
 gdb/disasm.c        |    2 +-
 gdb/doc/ChangeLog   |    5 +++
 gdb/doc/gdb.texinfo |   15 +++++++++-
 gdb/target-dcache.c |   81 +++++++++++++++++++++++++++++++++++++++++---------
 gdb/target-dcache.h |    4 ++-
 gdb/target.c        |   23 ++++++++++++--
 gdb/target.h        |    5 +++
 9 files changed, 156 insertions(+), 22 deletions(-)


hooks/post-receive
-- 
gdb and binutils


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]