This is the mail archive of the gdb-cvs@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

src/gdb ada-lang.h ada-lang.c ada-exp.y ChangeLog


CVSROOT:	/cvs/src
Module name:	src
Changes by:	brobecke@sourceware.org	2007-12-21 11:50:11

Modified files:
	gdb            : ada-lang.h ada-lang.c ada-exp.y ChangeLog 

Log message:
	* ada-lang.h (ada_renaming_category): New enumerated type.
	(ada_lookup_encoded_symbol): Declare.
	(ada_parse_renaming): Declare.
	(ada_renaming_type,ada_is_object_renaming)
	(ada_simple_renamed_entity): Delete declarations.
	* ada-lang.c (ada_parse_renaming): New function to concentrate
	extraction of information from renaming symbols.
	(parse_old_style_renaming): New function to concentrate
	extraction of old-style (purely type-based) renaming information.
	(renaming_is_visible): Rename to...
	(old_renaming_is_invisible): Rename and change sense of
	renaming_is_visible.
	(remove_out_of_scope_renamings): Rename to...
	(remove_irrelevant_renamings): Renames remove_out_of_scope_renamings
	and augments with additional logic to handle cases where the same
	object renaming is encoded both as a reference variable and an
	encoded renaming.
	(ada_renaming_type,ada_is_object_renaming)
	(ada_simple_renamed_entity): Delete definitions.
	(ada_lookup_encoded_symbol): New function factored out of
	ada_lookup_symbol.
	(ada_lookup_symbol): Reimplement to call ada_lookup_encoded_symbol.
	(wild_match): Don't reject perfect match of prefix.
	(ada_find_renaming_symbol): Factor old-style renaming logic into
	find_old_style_renaming_symbol.
	(find_old_style_renaming_symbol): New name for content of old
	ada_find_renaming_symbol.
	(ada_prefer_type): Reimplement not to use ada_renaming_type.
	* ada-exp.y (write_object_renaming): Change interface.  Reimplement
	to use new arguments and ada_parse_renaming.
	Correct blocks used to find array index.
	(write_var_or_type): Reimplement to use ada_parse_renaming.

Patches:
http://sourceware.org/cgi-bin/cvsweb.cgi/src/gdb/ada-lang.h.diff?cvsroot=src&r1=1.27&r2=1.28
http://sourceware.org/cgi-bin/cvsweb.cgi/src/gdb/ada-lang.c.diff?cvsroot=src&r1=1.109&r2=1.110
http://sourceware.org/cgi-bin/cvsweb.cgi/src/gdb/ada-exp.y.diff?cvsroot=src&r1=1.20&r2=1.21
http://sourceware.org/cgi-bin/cvsweb.cgi/src/gdb/ChangeLog.diff?cvsroot=src&r1=1.9013&r2=1.9014


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]