This is the mail archive of the frysk@sources.redhat.com mailing list for the frysk project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Outline Proposal: add getMaps() to abstract Proc.java


Phil Muldoon wrote:

In addition, I just realized that we might as well give the name of the map while "we are there", otherwise the user will just have to go to the same spot to find it. So add a String name; to the data of the maps class.



in Maps.java

// Think of a different name for this class
public class Map
{
   public long addressLow;
   public long addressHigh;
   public boolean permRead;
   public boolean permWrite;
   public boolean permExecute;
   public boolean shared;
   public long offset;
   public int devMajor;
   public int devMinor;
   public int inode;       public int pathnameOffset;
   public int pathnameLength;

   public void Map(....)
   {
      // implement constructor setters here
       ............
       ............
   }
}





Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]