This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Please try the latest snapshot -- it is close to cygwin 1.5.6

At 09:40 PM 12/26/2003 -0500, Christopher Faylor wrote:
>I tried the current CVS version and I don't see any stray tty garbage
>with inetd.  I never tried this with an older snapshot, however, so I
>don't know if I would have been lucky before.  I did try a much simpler
>test case which worked incorrectly with CYGWIN=tty and correctly after
>today's initial setsid change.

Here both exim and inetd are still off, with

CYGWIN_ME-4.90 hpn5170x 1.5.6(0.108/3/2) 2003-12-26 22:04 i686 unknown unknown Cygwin

The trace of sh -c inetd in on

The problem is the same, AFAICS there is an unaccounted for jump in usecount.

  177  298078 [main] SH 480747 fhandler_tty_slave::open: /dev/tty0 opened, incremented open_fhs 4, archetype usecount 4
  178  336409 [main] sh 480747 fhandler_tty_slave::dup: incremented open_fhs 5, archetype usecount 6

The trace also shows e.g. open_fhs -3

Still waiting for exim to misbehave.


Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]