This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Please try the latest snapshot -- it is close to cygwin 1.5.6

On Wed, Dec 24, 2003 at 04:20:37PM -0500, Pierre A. Humblet wrote:
>At 11:59 AM 12/24/2003 -0500, you wrote:
>>On Wed, Dec 24, 2003 at 10:29:51AM -0500, Pierre A. Humblet wrote:
>>>On Tue, Dec 23, 2003 at 05:28:16PM -0500, Christopher Faylor wrote:
>>>>The subject says it all.
>>>>I'm hoping to release cygwin 1.5.6 shortly after Christmas.
>>>On WinMe the queue runner forked by the exim daemon still occasionally
>>>produces a popup indicating an error in Cygwin1.dll
>>"a popup indicating an error".......?
>>Not too helpful.
>I tried stracing the child, but got the same popup for strace.  In
>previous trials I had failed to attach to the child from gdb.

Have you rebuilt strace?  It was broken in 1.5.5.

>After pushing the close button (on the child), I noticed that the
>parent (daemon) exim showed too many pinfos.  It had 7 pinfos mapped
>files, although it had no running child.  I then killed -9 it, there
>was no error message.

That's not necessarily a problem if exim had unreaped zombies.

>The exim log shows a few interesting things:
>The last mention of the child pid was 
>(that may be misleading, reuse is a possibility)
>2003-12-24 13:29:08 Start queue run: pid=159063
>2003-12-24 13:29:08 End queue run: pid=159063
>At around the time when I started looking into it, I see
>2003-12-24 15:35:26 Start queue run: pid=153375
>2003-12-24 15:35:26 End queue run: pid=153375
>2003-12-24 15:36:26 Start queue run: pid=34403247
>2003-12-24 15:36:26 End queue run: pid=34403247
>Note a 5 min gap here, then
>2003-12-24 15:42:26 daemon: fork of queue-runner process failed: Resource
>temporarily unavailable
>2003-12-24 15:43:27 Start queue run: pid=176243
>2003-12-24 15:43:27 End queue run: pid=176243
>2003-12-24 15:44:27 Start queue run: pid=157315
>2003-12-24 15:44:27 End queue run: pid=157315
>2003-12-24 15:45:27 Start queue run: pid=153375
>2003-12-24 15:45:27 End queue run: pid=153375
>2003-12-24 15:46:27 Start queue run: pid=34403247
>2003-12-24 15:46:27 End queue run: pid=34403247
>2003-12-24 15:47:27 Start queue run: pid=178263
>2003-12-24 15:47:27 End queue run: pid=178263
>There is again a gap here.
>Next is normal, I killed -9 the parent.
>2003-12-24 15:54:23 50 select() failures: Bad file descriptor
>There were no other gaps since 12:36:58, when I had started the daemon.

There's really nothing here that is useful, unfortunately.
Have you ever tried running exim via strace rather than trying
to attach to it when it has a problem?


Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]