This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

RE: CreateFileMapping, create global objects, and multiple users

Thanks to Benn Schreiber for sending me the trace.txt requested below
and for performing additional tests.

The problem is due to the tty mutexes and events being
created in the default name space.

That's a known issue already on my to-do list, but it's
queued behind other changes in the same files, currently
under review.

The fix is extremely simple: replace all tty constructs such as
__small_sprintf (buf, OUTPUT_MUTEX, ntty)
shared_name (buf, OUTPUT_MUTEX, ntty),
remove the %d from OUTPUT_MUTEX and adjust the size of buf.

The workaround with 1.5.5 is to avoid using tty and rxvt with TS
(and more than one cygwin user).
Another workaround with the recent snapshots is to be unprivileged.


At 07:54 PM 12/15/2003 -0500, Pierre A. Humblet wrote:
>At 04:39 PM 12/15/2003 -0800, Benn Schreiber wrote:
>>Thanks for the feedback. One of the users is the administrator. The
>>other is not in the admin group, but has the 'create global object'
>>right per a note I saw from Corinna.
>>The snapshot I installed is from 12/1, should this be recent enough?
>There has been another significant change on 12/2. Could you try the
>latest snapshot? It's stable enough.
>>It does not appear to depend on the order. Both the root (administrator)
>>and user login are via terminal services. I just tried it with
>>administrator logged in locally, as well as through TS, and it still
>>occurs. I also noticed (one time only) that tcsh (my default shell) goes
>>compute bound. I tried it with bash, and the rxvt window seems to
>>more-or-less self-destruct on its own (ie I don't even get the
>>opportunity to close just goes away as soon as I touch it).
>So at the time the second login takes place, the first one freezes,
>even when both are the administrator? 
>>The times when the window is hung, I cannot type anything into the
>>window. The only thing I can do is close it.
>>Thanks for your thoughts...any additional ideas would be appreciated.
>Assuming it keeps occuring with the snapshot, try starting under strace
>(from the Terminal Services console) the rxvt that goes away:
>strace -o trace.txt rxvt -d :0 -e bash
>and send me trace.txt as an attachment.
>Do as little as possible in bash (no --login) to keep the trace
>size reasonable. Is there a stack dump in the current directory?
>>-----Original Message-----
>>From: Pierre A. Humblet [] 
>>Sent: Monday, December 15, 2003 4:15 PM
>>To: Benn Schreiber;
>>Subject: Re: CreateFileMapping, create global objects, and multiple
>>At 11:33 AM 12/15/2003 -0800, Benn Schreiber wrote:
>>>I'm running Win2003 server and found an interesting anomaly with the
>>>global objects' right workaround. I have it enabled for administrator
>>>(obviously), and my account. When I am logged into both admin and my
>>>account, and both create rxvt windows, the first one created gets hung,
>>When? Does it depend of the order? Are you in the administrators group?
>>Do you both login over terminal services or is one of you at the
>>> and doing anything to it results in the window disappearing.
>>So it's not really hung... What do you mean exactly?
>>>Is there a naming conflict or something, such that there can only be
>>>Cygwin user on a Win2003 server?
>>Obviously there is "something", but it shouldn't be there.
>>There have been lots of changes to that part of Cygwin.
>>Could you try with a recent snapshot and report again?
>Unsubscribe info:
>Problem reports:

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]