This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

RE: CreateFileMapping, create global objects, and multiple users


Thanks for the feedback. One of the users is the administrator. The
other is not in the admin group, but has the 'create global object'
right per a note I saw from Corinna.

The snapshot I installed is from 12/1, should this be recent enough?

It does not appear to depend on the order. Both the root (administrator)
and user login are via terminal services. I just tried it with
administrator logged in locally, as well as through TS, and it still
occurs. I also noticed (one time only) that tcsh (my default shell) goes
compute bound. I tried it with bash, and the rxvt window seems to
more-or-less self-destruct on its own (ie I don't even get the
opportunity to close just goes away as soon as I touch it).

The times when the window is hung, I cannot type anything into the
window. The only thing I can do is close it.

Thanks for your thoughts...any additional ideas would be appreciated.


-----Original Message-----
From: Pierre A. Humblet [] 
Sent: Monday, December 15, 2003 4:15 PM
To: Benn Schreiber;
Subject: Re: CreateFileMapping, create global objects, and multiple

At 11:33 AM 12/15/2003 -0800, Benn Schreiber wrote:
>I'm running Win2003 server and found an interesting anomaly with the
>global objects' right workaround. I have it enabled for administrator
>(obviously), and my account. When I am logged into both admin and my
>account, and both create rxvt windows, the first one created gets hung,

When? Does it depend of the order? Are you in the administrators group?
Do you both login over terminal services or is one of you at the
> and doing anything to it results in the window disappearing.

So it's not really hung... What do you mean exactly?
>Is there a naming conflict or something, such that there can only be
>Cygwin user on a Win2003 server?

Obviously there is "something", but it shouldn't be there.
There have been lots of changes to that part of Cygwin.
Could you try with a recent snapshot and report again?


Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]