This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

vtable with snapshot >=20031123


I ran into a problem with gcc 3.3.1, cygwin snapshots>=20031123 (at least, probably also earlier versions). The binary built from the attached sources (with vtbllib.hpp's INLINE_CTOR defined) coredumps. It seems that the vtable is invalid, probably because a class's vtable is created for each translation unit (it only crashes if the c'tor is inlined; #undef INLINE_CTOR fixes vtbl.exe).

This did not happen with earlier versions of cygwin (1.4*); as far as I can remember even gcc 3.3.1 with cygwin 1.4* worked. This is why I believe it's a cygwin problem, not a gcc problem - but I'm really just guessing.

Could you tell me if you can reproduce this, and whether it's cygwin or gcc or me? If you need more info on my system please let me know (in general: everything up to date, yesterday's cygwin setup.exe installation except for the cygwin snapshot).


Attachment: vtbl_inline.tar.gz
Description: application/gzip

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]