This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Setup hangs in postinstall

Michael Robbert wrote:
I'm sorry, I don't have a copy of XP to try this with, but it would
appear to be a bug in uname (since it gives no output from the commandline)

Does it uname hang or just return empty? Is there any error codes? Try:

/bin/uname -a ; echo $?

Also, could you *attach* (uncompressed) the output of:

/bin/cygcheck -svr > cygcheck.out



the uname command by itself does not hang or return empty, it is only in the process of assigning the output of the command(any command) to a variable that it hangs.
Here is the output of your example:

bash-2.05b$ /bin/uname -s; echo $?

I have attached the file cygcheck.out which contains the out from the command "cygcheck -svr"

I don't think that your problem is exactly the same as mine either. You problem, from what I gather in your post, only happens in a loop and possibly on a dual CPU(SMP) machine. I am getting this on a single command on a laptop(not SMP).

If anybody wants to point to bash as the problem, let me also point out that I have been able to replicate the problem in zsh, csh, and sh.

Actually, I still do believe it's the same problem. In some other mails I specified it happens also on single CPU machines. I think other people have been able to reproduce it as well. The fact I expose it in a loop is because the hang is random. It also sometimes happen in a non-loop environment. I suspect a nasty race condition which depends heavily on the system scheduling, so in your case the same problem might happen every time.
In any case, I tried my small test case with zsh too, same result : hang after a few iterations.


Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]