This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Setup hangs in postinstall

A co-worker and I are trying to debug a problem that we came across while trying to do a new install of Cygwin on a clients computer. We have the current version of Setup.exe(2.416) and we have tried to install from a couple of mirrors, but even when doing just a base install the process hangs on two postinstall scripts. and
If you hit cancel in setup you end up with a partially working system. I have been able to open a bash shell and kill those processes and the rest of the scripts run fine. I then try to run the scripts manually and they still hang. I have run them with sh -x to see where they're getting stuck and I have found that it is any time they try to assign a variable to the output of a command i.e.: OSNAME="`/bin/uname -s`"
I can reproduce the problem with just that line on from a bash or sh shell prompt. I have also tried to strace this command, but I get no output at all. Setting variables to a simple string works fine.

What is interesting is that the problem happens on both my laptop and the clients workstation, but not my co-workers laptop. They are all running XP SP1. I also can not reproduce the problem on another laptop that is running Windows 2000 SP4. There are a few less minor patches on my co-workers laptop, but that is the only difference that we can think of. What else can we look at to find out why this problem is happening on two computers, but not others?

Michael "Murph" Robbert
System Administrator for Math/CS
Colorado School of Mines, Golden, CO  80401-1887
Office: GC249
Office phone: 303-273-3786
Pager: 303-461-6543

-- Unsubscribe info: Problem reports: Documentation: FAQ:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]