This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: setup hangs when installing keychain

On Fri, 5 Dec 2003, Karl M wrote:

> Hi All...
> I just tried to update keychain on two machines, both win2k. In both
> cases, setup (the version currently on the Cygwin web page) downloads
> and then when it says it is installing, goes to 100% CPU and starts
> eating up memory until the machine runs out of memory.
> I tried a reboot, and an uninstall/reinstall to no avail.
> I looked at the downloaded files (I was looking for a postinstall) and
> didn't get any clues.
> I can send a cygcheck, but I'm not sure that is is relevant for this.
> 1) Can others reproduce this?
> 2) What else can I do to track it down?
> Thanks,
> ...Karl


This could be some weird mount issue. or a directory in place where a
symlink should be in the package...

Can you "Cancel" out of setup?  If so, look at the resultant
/var/log/setup.log.full for clues.  If not, run setup under gdb - even
with a non-debug version, the log messages should be printed on the
console, and you'll able to see them.

I think someone also reported similar behavior when the package file was
corrupted.  Try downloading the package using 'wget' instead, and check
its MD5 sum.  Also, try to 'tar tjf' the package tarball.
      |\      _,,,---,,_
ZZZzz /,`.-'`'    -.  ;-;;,_
     |,4-  ) )-,_. ,\ (  `'-'		Igor Pechtchanski, Ph.D.
    '---''(_/--'  `-'\_) fL	a.k.a JaguaR-R-R-r-r-r-.-.-.  Meow!

"I have since come to realize that being between your mentor and his route
to the bathroom is a major career booster."  -- Patrick Naughton

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]