This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Issues with cygrunsrv: How I solved mine

On Wed, 30 Oct 2002, Jim Drash wrote:

> Environment:
> Windows 2000 Service Pack 3
> In a domain
> I installed Cygwin as "Just for Me"
> I had the same error 1062 that everyone seems to get trying to start a
> service. In my case cron and httpd.  I re-installed Cygwin for "All Users"
> and all of the 1062 errors disappeared.  I suspect that the combination of
> being in a domain and doing a "Just for Me" install was the root cause of
> my problem.
> I hope this helps other people.
> -- jim drash

Just to clarify the above.

Being in a domain shouldn't affect sshd and httpd, provided the relevant
domain users (i.e., those that need to log in) are in the /etc/passwd

Installing Cygwin "Just for Me" will result in the SYSTEM user (that
services, especially sshd, should run as) not seeing the mounts, and thus
not being able to access the relevant files.  For the same reason, the
value of CYGWIN is better set as a system environment variable, rather
than a user one.

To fix this without reinstalling Cygwin, try remounting "/", "/usr/bin"
and "/usr/lib" as system (with the "-s" flag).
      |\      _,,,---,,_
ZZZzz /,`.-'`'    -.  ;-;;,_
     |,4-  ) )-,_. ,\ (  `'-'		Igor Pechtchanski
    '---''(_/--'  `-'\_) fL	a.k.a JaguaR-R-R-r-r-r-.-.-.  Meow!

"Water molecules expand as they grow warmer" (C) Popular Science, Oct'02, p.51

Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]