This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

telnetd doesn't give login: prompt

I (still) can't use telnet for my NT box.  The test I'm stuck on is when I try to
run telnetd (i.e. without using inetd).

In one window I run:

    $ /usr/sbin/in.telnetd -debug

and in another I run:

    $ telnet $(uname -n)

I get the following:

Connected to
Escape character is '^]'.

that is, I'm prompted for a password without first having entered my login-id.
Naturally, no password works.  Once I try something, I do indeed get a prompt
for a login-id:

Login incorrect

Now, I'm trying to remember how it works on unix: init starts getty which, if I
remember correctly, paints the first login prompt and gets the login-id.  At
that point, login(1) is called.  Right?

What is the equivalent under Cygwin?

BTW, I created /etc/passwd w/ mkpasswd -d $USERDOMAIN -u $USERNAME

$ lf /bin/cygwin*     

I used (a while ago) iu-config to create the files in /etc.

$ whence login

$ echo $CYGWIN 

Any help will be appreciated...


Thomas Mellman
WEB.DE Club - jetzt testen fur 1 Euro! Nutzen Sie Ihre Chance 

Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]