This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

RE: Rsync over ssh hangs on win2k

Even further investigation.  I learned of the -vvv flag.   The tail end of
the output follows.

set modtime of WINNT/twain_32/miitwain to (1001999972) Tue Oct  2 00:19:32
generate_files phase=1

I'm reading the source to try and figure out where things went wrong.  Any
insights would be helpful.

	David Hinkle

-----Original Message-----
From: Dave Hinkle 
Sent: Tuesday, September 24, 2002 5:33 PM
To: ''
Subject: RE: Rsync over ssh hangs on win2k

Please CC any responses to me, as I'm not on the list.

Further investigation.   I've figured out how to start up the debugger under
gygwin.  I attach to the process and do a back trace but it doesn't tell me
anything :(  I am quite good with gdb under linux but I've never seen output
like this.

$ gdb /bin/rsync.exe --nw
GNU gdb 5.0 (20010428-3)
Copyright 2001 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i686-pc-cygwin"...
(gdb) attach 5396
Attaching to program `/bin/rsync.exe', process 5396
[Switching to thread 5396.0x854]
(gdb) list
851             signal(SIGSEGV, rsync_panic_handler);
852             signal(SIGFPE, rsync_panic_handler);
853             signal(SIGABRT, rsync_panic_handler);
854             signal(SIGBUS, rsync_panic_handler);
855     #endif /* def MAINTAINER_MODE */
857             starttime = time(NULL);
858             am_root = (getuid() == 0);
860             memset(&stats, 0, sizeof(stats));
(gdb) bt
#0  0x77f97705 in _libkernel32_a_iname ()
#1  0x77ea1982 in _libkernel32_a_iname ()
#2  0x77e887dd in _libkernel32_a_iname ()
(gdb) detach
Detaching from program: /bin/rsync.exe thread 5396.0x854
(gdb) quit

After I detach the rsync dissapears.  What am I seeing here? Is there a
reference for debugging under cygwin?


-----Original Message-----
From: Dave Hinkle 
Sent: Tuesday, September 24, 2002 4:27 PM
To: ''
Subject: Rsync over ssh hangs on win2k

Please CC any responses to me, I'm not subscribed to the list.   When I try
to rsync a directory structure from a windows 2000 machine running cygwin to
my linux system (running it from the linux side) the transfers always hang.
Everything works beautifully to and from linux.  This isn't the bug where
rsync hangs after it's done, I'll just work around that.   (I've seen it
when I initiate a rsync from the windows box)

This happens on every one of half a dozen windows machines I've tried it on,
I'm surprised more people havn't seen it. 

I get no error messages, but rsync's processor utilization drops to zero on
both sides.  

I run the following command from my linux box (raid) to the windows box

rsync -avzx --ignore-errors --delete-excluded --delete --progress
--exclude-from=system/excludes -e ssh
Administrator@ profit/2002-09-24_11+51/

The following is all I see in a TCP dump when things go wrong:

15:10:42.248139 raid.34418 > . 37767:39227(1460) ack
1914864 win 62780 (DF) [tos 0x8]
15:10:42.248224 raid.34418 > . 39227:40687(1460) ack
1914864 win 62780 (DF) [tos 0x8]
15:10:42.271624 > raid.34418: . ack 40687 win 556 (DF)
15:10:42.559003 raid.34418 > P 40687:41243(556) ack
1914864 win 62780 (DF) [tos 0x8]
15:10:42.740027 > raid.34418: . ack 41243 win 0 (DF)
15:10:43.069022 raid.34418 > . ack 1914864 win 62780
(DF) [tos 0x8]
15:10:43.084147 > raid.34418: . ack 41243 win 0 (DF)
15:10:43.739017 raid.34418 > . ack 1914864 win 62780
(DF) [tos 0x8]
15:10:43.744416 > raid.34418: . ack 41243 win 0 (DF)

These lines are then repeated forever as far as I can tell: 
15:10:43.739017 raid.34418 > . ack 1914864 win 62780
(DF) [tos 0x8]
15:10:43.744416 > raid.34418: . ack 41243 win 0 (DF)

My rsync version is 2.5.5.  

Doesn't take it long at all to hang, and it happens every time.

I've seen a couple people asking about this in the list archives but no
answers (They appear to have been drowned out by the people with the hang
after completion bug)

If anybody has any idea's on where to start, please e-mail me back.  This is
for a project that's very important to me, so I'll be willing to do whatever
is necessary to help you debug.

	David Hinkle

Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]