This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

RE: compilation problems

I just realized that I might not have explained the real problem very well.
I've seen the problem come up in the following example.

I ftp my source&makefiles from Unix to my Win PC.  The ftp program does a
converion on the text files to make them compatible with DOS (which means
changing a cr to a cr+lf).  [someone please correct me if I don't have that
right]  So then, under Cygwin, I tar.gz my whole source tree and ftp it to
another Unix box (yes, I've done this, please don't give me a hard time
about it ;).  That transfer is done in Binary conversions done.
If I try to make the program at this point, I'll get the same "missing
seperator" message (same message I get if GNU make is not in my path before
the native make).  Anyway, opening the file in vi reveals a '^M' at the end
of each line...aparently this is the extraneous LF from DOS.  So I solve the
problem by ftp'ing each text file individually in text mode if I go from
Unix to DOS.

Hope this helps,

-----Original Message-----
From: Cal Thorne []
Sent: Thursday, October 14, 1999 9:19 AM
To: 'Jean Michel Cirba'; ''
Subject: RE: compilation problems


The only problem I could see was the dreaded '^M' at the end of your file.
Must've been opened with a DOS prog or something (I'm still not clear on all
the semantics of the nl/cr issue).  Anyway, I think I deleted it in the file
I include with this post.

Good Luck!


-----Original Message-----
From: Jean Michel Cirba []
Sent: Thursday, October 14, 1999 9:09 AM
To: ''
Subject: compilation problems

Hi !

I'm impressed by your product package (the unix-like api, gcc and gdb) which
has allowed me to write, debug and run my programs as i would do in an Unix
Besides, the api is very similar and contains nearly all the unix and shell

However i have a strange problem:
when compiling from a file that contains the different gcc lines, OK !
when using a makefile and make (UNIX mode), i have the persistent following
error message:
	missing separator

I have unix-like makefiles :
directories described using forward slashes (with or without full path
description ie /cygnus/cygwin-b20/cgi or c:/cygnus/...). I've also tried the
variable description of the like : DIR_EXE=/cygnus/... and calling with
the standard gcc options (which i use in the text file i compile from)

Have you got any idea ??

(i've included a sample makefile)


Want to unsubscribe from this list?
Send a message to

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]