This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: Making Cygwin write DOS style text files

--On Saturday, October 02, 1999, 9:04 PM -0700 Earnie Boyd
<> wrote:

> --- Glenn Spell <> wrote:
>> On 29 Sep 1999 around 8:08PM (+0200) Rabbe Fogelholm wrote:
>> > [...] but other users out there will think that my Cygwin-based
>> > script does a poor job if it produces files that "look weird" in
>> > the Microsoft environment.
>> > 
>> > So, while I consider the CR LF convention to be among the stupidest
>> > of this century, I still have to stick to it :-(.
>> You have been assimilated. :-)
>> Although not as elegant as awk, you may find Rahul Dhesi's
>> 'flip' useful. There's a Cygwin port with man pages at
>> <>.
>> > It turns out that I was on a text!=binary mount, and that creating
>> > a text=binary mount did not solve my problem (either way I get
>> > files with a single LF as the end-of-line sequence).
>> I don't understand why you're getting those type files with text
>> mounts (text!=binary). I use text mounts and only text mounts on
>> Win95 to achieve what I think you are after. Most files created with
>> Cygwin tools on my setup have CR/LF pairs for line endings. I thought
>> that was the purpose of text mounts!
> There is a bug in the stock b20.1 cygwin that could cause this.  See
> my pages, the cygwin documentation pages at
> and the mail archives for more
> information on this.
> =====
> Earnie Boyd <>

Thanks Glenn and Earnie for taking your time with this. I am now in a
bit of a hurry so I will drop my investigations for the time being. I
am beginning to suspect that what I saw was some kind of flaky
behaviour in Cygwin, because yesterday I could not reproduce the
"missing CR" syndrome any more. I tried uninstalling Cygwin and
deleteing the installation directory, but still no "missing CR". BTW,
uninstall does not clear all traces of the installation, my "mount"
info was still present after reinstalling.

Also, it may well be that the more recent cygwin1-19990115.dll would
have cured this problem in the first place. Once again, thanks everyone.

--Rabbe Fogelholm, Ellemtel, Stockholm, Sweden

Want to unsubscribe from this list?
Send a message to

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]