This is the mail archive of the mailing list for the Cygwin project. See the Cygwin home page for more information.
[Date Prev][Date Next][Thread Prev][Thread Next]
[Date Index] [Subject Index] [Author Index] [Thread Index]

Re: Compiling Perl under b20.1

Sebastien Barre wrote:

> At 13:27 06/03/99 -0500, Charles Wilson wrote:
> >BTW, did you apply the patch to a
> >pristine copy of the source, or had you already applied the changes from Teun
> >Burgers (below)?
> No, from the pristine copy of course :) My perl is working quite right I
> guess, I just wanted to help you controlling your build package, so I
> started from the beginning, following your statements.

I was fairly sure that was the case, but it's best to eliminate the simple things

> <snip>

> Therefore, I guess that this information

> *definitely* need a place in your build instructions : egcs 1.1.1 might be
> handy.

Okay. I'll update the build-kit soon.

> <snip>

> >However, I

> >don't see how including Mr. Burgers' fixes will hurt anything, so I'll go
> ahead an
> >add them to the "patch", unless anyone can think of a good reason not to.
> I tried, but was unable to find the relevant part to patch.

I found the relevant part, and have changed the build-kit to include this patch.
Even though it probably doesn't matter if you're using egcs-1.1.1.

> >> *) Furthermore, I'd just add that I had some problems while building perl
> >> if source files were extracted in a binary mounted partition. BUT I also
> >> read some testimony regarding the contrary (i.e. you need to mount it as
> >> binary) ! Therefore, It's just a hint, but if you experience some problems
> >> (sadly, I forgot to save the error messages), try different mount mode.
> >I extracted into a binary mounted partition. My *guess* is that you might have
> >used WinZip or somesuch to extract the source. If WinZip converted all
> >newlines to \013\010, AND the partition was mounted binary, then that
> would cause problems.
> Nope, I'm aware of the Winzip problem, and I'm taking care of that, by
> systematically using tar / gzip :)

Well, then I'm stumped. I don't know what the *build* problem is (or even if there
is one, after applying all these patches) under text / binary mounts. *make test*
problems are a whole different kettle of fish....continued in next message.

Want to unsubscribe from this list?
Send a message to