This is the mail archive of the mailing list for the Cygwin project. See the Cygwin home page for more information.
[Date Prev][Date Next][Thread Prev][Thread Next]
[Date Index] [Subject Index] [Author Index] [Thread Index]

b20.1 bug, developers please help

Hi there!

I've trying to modify a unix program that works perfect on unix
and doesn't work on windows. It compiles, I changed
code so it could compile without any help on both systems.

At the beginning the problem was with fork(), but I downloaded
the lastest snapshops and it doesn't seems to crash there.
(I am using windows 98 by the way).

Anyway, when the program is launched to run foreground,
it works perfect, but when launched on the background, it crash.
I am not sure if it is still a fork bug or a tty bug or what it is
since I can't figure it out.
I am sure it is not my program bug since it runs an compile on several
unixes, so could you take a look at it and see what's the problem?
I am becoming crazy, I already changed makefiles and everything
to suit the cygwin environment.
You can download the program at:

make install DEST=/directory

Once you configure the kaosbot.conf.dist

It runs perfect as:
./kaosbot -c kaosbot.conf.dist -ntm

But it crash as:
./kaosbot -c kaosbot.conf.dist
(which is the default since it goes to background).

I have been 2 months trying it, at the beginning it was
a fork bug on cygwin, but now with the snapshops i
am not sure if that is the case since it dies a while

To check if the program is still really working:
telnet localhost 3333

If it doesn't answer it is because it crashed.

Thank you
Joaquin Grech
!     C r e a t i v i t y     M u s t    S u r v i v e        !
!  Fido: 2:341/19.67                 Euronet: 25:928/100.67   !
!  Internet:                            !
!  Http://                  Ya me direis :)   !

Want to unsubscribe from this list?
Send a message to