This is the mail archive of the mailing list for the crossgcc project.

See the CrossGCC FAQ for lots more information.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [linux-sh:02796] sh4 problem: "/lib/ no version information available"

On Wed, Jun 18, 2003 at 09:22:48AM -0700, Dan Kegel wrote:
> Daniel Jacobowitz wrote:
> >>>>Oddly enough, objdump -p shows that there is indeed no 
> >>>>version info in built for 
> >>>>sh4-unknown-linux-gnu/gcc-3.3-glibc-2.2.5
> >>>>or sh4-unknown-linux-gnu/gcc-3.3-glibc-2.3.2 ...
> >>
> >>... Looks like libstdc++-v3/configure
> >>is setting SYMVER_MAP=config/linker-map.dummy because it sees that
> >>no was generated; configure says
> >>checking for shared libgcc... no.
> >>This happened even though I ran gcc's configure with --enable-shared!
> >
> >Oh!  I remember this one now.  It's been on my list to fix for a while
> >but I never got around to it.  That test is broken, period.
> Aha.  So should I just force SYMVER_MAP to config/linker-map.gnu
> for the nonce?

Well, I brute-forced the check by making links with -lgcc_s succeed. 
That worked in my setup but might not in yours.  --enable-symvers=gnu
should do the trick anyway.

Daniel Jacobowitz
MontaVista Software                         Debian GNU/Linux Developer

Want more information?  See the CrossGCC FAQ,
Want to unsubscribe? Send a note to

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]