This is the mail archive of the
mailing list for the binutils project.
RE: [PATCH, MIPS] Support shared library debug with MIPS PIE
- From: Matthew Fortune <Matthew dot Fortune at imgtec dot com>
- To: Richard Sandiford <rdsandiford at googlemail dot com>
- Cc: "binutils at sourceware dot org" <binutils at sourceware dot org>, "Maciej W. Rozycki (macro at linux-mips dot org)" <macro at linux-mips dot org>
- Date: Tue, 23 Jun 2015 21:25:04 +0000
- Subject: RE: [PATCH, MIPS] Support shared library debug with MIPS PIE
- Authentication-results: sourceware.org; auth=none
- References: <6D39441BF12EF246A7ABCE6654B0235321175C6A at LEMAIL01 dot le dot imgtec dot org> <87381ii9iy dot fsf at googlemail dot com>
Richard Sandiford <email@example.com> writes:
> Matthew Fortune <Matthew.Fortune@imgtec.com> writes:
> > diff --git a/ld/testsuite/ld-mips-elf/pic-and-nonpic-3b.ad b/ld/testsuite/ld-mips-
> > index 227d15d..802bb71 100644
> > --- a/ld/testsuite/ld-mips-elf/pic-and-nonpic-3b.ad
> > +++ b/ld/testsuite/ld-mips-elf/pic-and-nonpic-3b.ad
> > @@ -8,6 +8,7 @@ Dynamic section at offset .* contains .*:
> > 0x0000000a \(STRSZ\) .*
> > 0x0000000b \(SYMENT\) .*
> > 0x70000016 \(MIPS_RLD_MAP\) * 0x80000
> > + 0x70000035 \(MIPS_RLD_MAP2\) * 0x3dfc8
> > 0x00000015 \(DEBUG\) * 0x0
> > 0x00000003 \(PLTGOT\) * 0xa0000
> > 0x70000001 \(MIPS_RLD_VERSION\) * 1
> For these and similar tests I think it would be better to stub out the
> address with .*, so that there's less to update if the gap grows or shrinks
> due to some other later change. It doesn't seem worth matching a particular
> value when we have "Dynamic section at offset .*"
Fine with me. It's always difficult to gauge the right level of detail in
these dump tests. I certainly don't want to be perpetually updating them.
> Obviously this doesn't apply to your new tests. :-)
> Looks good to me with that change.
Thanks. I'll give it 48hrs to see if anyone shows interest in this feature
as per Maciej's request and then commit if not. I'm also happy to use
Maciej's proposed DT_MIPS_RLD_MAP_REL as the name so will switch to that.