This is the mail archive of the mailing list for the binutils project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH] update automake version to 1.11.6

On 23 Mar 2015 05:46, Joel Brobecker wrote:
> > > i don't have a problem with requiring people to use the same exact
> > version.
> > > i do think that requiring them to build/install by hand is
> > > unreasonable.  it's pretty rare (by design) for projects to do this
> > > sort of thing (commit the generated autotools), so it's pretty rare
> > > for this to be an issue, so it's pretty rare for people to be
> > > required to manage this.  it's a throw back to pre-distro days when
> > > people were used to building/install software themselves, and it's
> > > unnecessary friction for new people to get into the development
> > > process today.  death by a thousand cuts and all that.
> > 
> > It's only a barrier for people who need to change the or
> > files, which is not most developers.
> Agreed.

i hit it on every machine i want to develop on, and i don't have the luxury of 
running Gentoo on every system

> Also, I don't think that building autoconf and automake once every
> few years, and then using that to generate the files is really that
> much of a barrier.

multiplied by every machine you develop on, and every user that wants to make 
their own contribution here

Attachment: signature.asc
Description: Digital signature

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]