This is the mail archive of the mailing list for the binutils project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Configuring Gas for the Z80

Hi. I currently have a version of the GNU assembler installed on my computer. I would like to install another version in another directory that's configured to target the z80 processor. I have tried doing these steps but still get an error:

  extract the tarball
  mkdir dest
  cd dest
  /.../binutilsXXX/configure --target=z80-unknown-coff (and sometimes --prefix=/.../dest/)
 make all-gas
 make install

I also changed the code in the /gas/config/tc-z80.c file because it was getting errors. I used this link's patch to do this

The error that I am getting is:

make[5]: Nothing to be done for `install-exec-am'.
test -z "" || /usr/bin/mkdir -p ""
test -z "" || /usr/bin/mkdir -p ""
make[5]: Leaving directory `/home/nkemp/Documents/.../z80/bfd'
make[3]: *** [install-recursive] Error 1
make[3]: Leaving directory `/home/nkemp/Documents/z80/bfd'
make[2]: *** [install] Error 2
make[2]: Leaving directory `/home/nkemp/Documents/z80/bfd'
make[1]: *** [install-bfd] Error 2
make[1]: Leaving directory `/home/nkemp/Documents/z80'
make: *** [install] Error 2

I also went through these steps in this link: 

I am trying to install version 2.24 but I have also tried 2.23 and 2.23.2. I'm assuming that the error "nothing to be done for 'install...'" is because I already have a version installed on my comp. 

My questions are is there are way to have two versions of gas on the same machine? and if there is what am I doing wrong?

Thanks for any help

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]