This is the mail archive of the
mailing list for the binutils project.
Re: [PATCH] include/gdb/section-scripts.h: New file.
- From: Doug Evans <xdje42 at gmail dot com>
- To: Tom Tromey <tromey at redhat dot com>
- Cc: Doug Evans <dje at gmail dot com>, gdb-patches at sourceware dot org, binutils at sourceware dot org
- Date: Mon, 2 Dec 2013 09:00:50 -0800
- Subject: Re: [PATCH] include/gdb/section-scripts.h: New file.
- Authentication-results: sourceware.org; auth=none
- References: <m3fvqf3unp dot fsf at sspiff dot sspiff dot org> <87eh5vwaa3 dot fsf at fleche dot redhat dot com>
On Mon, Dec 2, 2013 at 7:19 AM, Tom Tromey <firstname.lastname@example.org> wrote:
>>>>>> "Doug" == Doug Evans <email@example.com> writes:
> Doug> This patch creates a file to use when adding values to
> Doug> .debug_gdb_scripts.
> I don't see why this needs to go in include.
So you would have code that puts contents in this section using magic numbers?
Eh? This doesn't make any sense. Why does dwarf2.def exist (for example) ?
[The dwarf format is far more complicated, obvously. But I didn't
know there was
a threshold of magic numbers was required before a header was allowed.]
> I think it would be more helpful to document the format of this section
> in the manual.
Documentation can always be improved, but there is something there already.
I do need to spiff it up, that's coming ...
> Doug> +/* Native GDB scripts are not currently supported in .debug_gdb_scripts,
> Doug> + but we reserve a value for it. */
> Doug> +/*#define SECTION_SCRIPT_ID_GDB_FILE 2*/
> There's no need either to reserve a value or to add commented out code.
I'm curious how I would apply this rule in general.