This is the mail archive of the
mailing list for the binutils project.
Re: [PATCH] MIPS opcode table loads
- From: Richard Sandiford <rdsandiford at googlemail dot com>
- To: "Moore\, Catherine" <Catherine_Moore at mentor dot com>
- Cc: "binutils\ at sourceware dot org" <binutils at sourceware dot org>
- Date: Sat, 09 Nov 2013 11:22:10 +0000
- Subject: Re: [PATCH] MIPS opcode table loads
- Authentication-results: sourceware.org; auth=none
- References: <FD3DCEAC5B03E9408544A1E416F11242012EA8D017 at NA-MBX-04 dot mgc dot mentorg dot com> <87habqsmfv dot fsf at talisman dot default> <FD3DCEAC5B03E9408544A1E416F11242012EA8FDD6 at NA-MBX-04 dot mgc dot mentorg dot com>
"Moore, Catherine" <Catherine_Moore@mentor.com> writes:
>> The patch adds the new flag to coprocessor as well as GPR loads, so the
>> name seems a bit misleading. I think we should either
>> (a) restrict it to GPR loads and continue to use
>> for coprocessors or
>> (b) rename it to INSN_LOAD_MEMORY and include it in CLD:
>> #define CLD (INSN_LOAD_MEMORY|INSN_COPROC_MEMORY_DELAY)
>> I've a slight preference for (2) because of the symmetry with
>> INSN_STORE_MEMORY. The flag would then be LM, for consistency with
>> At some point we should also add it to the MIPS16 and microMIPS tables, but
>> that can wait.
> I have a patch for the microMIPS opcode table that I'll post separately.
> I've rewritten the patch to conform to suggestion #2. It's attached.
> Okay to commit?
Following on from Maciej's microMIPS comment, we'd better include LM
in ACLR and ASET here too.
OK with that change, thanks.