This is the mail archive of the
mailing list for the binutils project.
Re: [committed] Replace field-based RD_ and WR_ flags with position-based ones
- From: Richard Sandiford <rdsandiford at googlemail dot com>
- To: binutils at sourceware dot org
- Date: Thu, 01 Aug 2013 23:35:44 +0100
- Subject: Re: [committed] Replace field-based RD_ and WR_ flags with position-based ones
- References: <87li4l871z dot fsf at talisman dot default>
Richard Sandiford <email@example.com> writes:
> This patch replaces field-based flags like RD_s, WR_d, etc., with
> position-based ones like WR_1 (write to first operand), RD_2, etc.
Just noticed that I'd left a dangling WR_s in micromips-opc.c. Also,
I forgot to say that I'd kept RD_a and WR_a as aliases for now,
both because we don't really model the ACX component properly and
because there doesn't seem to be a real need to distinguish $ac0-$ac3
in GAS at the moment.
* micromips-opc.c (WR_s): Delete.
--- opcodes/micromips-opc.c 2013-08-01 21:54:51.901028141 +0100
+++ opcodes/micromips-opc.c 2013-08-01 23:28:44.919946043 +0100
@@ -196,7 +196,6 @@ #define RD_31 INSN2_READ_GPR_31
#define RD_pc INSN2_READ_PC
/* For 32-bit microMIPS instructions. */
-#define WR_s INSN_WRITE_GPR_S
#define WR_31 INSN_WRITE_GPR_31
#define WR_CC INSN_WRITE_COND_CODE