This is the mail archive of the mailing list for the binutils project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Map "" and ".text.unlikely" input section prefixes to separate output sections.

On Mon, Nov 19, 2012 at 2:52 PM, Alan Modra <> wrote:
> On Fri, Nov 16, 2012 at 05:19:01PM -0800, Ian Lance Taylor wrote:
>> On Wed, Nov 14, 2012 at 5:06 PM, Sriraman Tallam <> wrote:
>> >> Ideally gold should group all input sections with the same name
> I strongly disagree.  Grouping sections with the same name is a bad
> idea, unless the name gives you some infomation from the compiler (as
> it does with* et al).  The problem with grouping sections
> with the same name is that with -ffunction-sections objects, you'll
> potentially move functions away from their callers, losing cache
> locality.  The canonical example is a number of object files with
> static "setup" functions.  These will all have code in .text.setup,
> but there is no good reason to group these sections.

That is a good point.

Unfortunately it leaves us adding more special cases for section
names, which I really dislike.  Is there any happy medium?


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]