This is the mail archive of the binutils@sourceware.org mailing list for the binutils project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [patch] Gold linker patch to provide plugin support for mapping some text sections to an unique ELF segment.


On Wed, Aug 22, 2012 at 8:12 PM, Sriraman Tallam <tmsriram@google.com> wrote:
> Hi Ian,
>
>     I have made all the changes and attached the patch.

> +  flags = this->get_output_section_flags (flags);

No space before parenthesis.

> +    // Identifier for the Segment.  ELF Segments dont have names.
> +    const char* name;
> +    // Additional Segment flags.

s/Segment/segment/ three times.

> +  void
> +  set_segment_alignment(uint64_t align)
> +  { this->segment_alignment_ = align; }
> +
> +

Only one blank line here.

> +/* The linker's interface for specifying that a specific set of sections
> +   must be mapped to a unique segment.  ELF segments do not have names
> +   and the NAME is used as an identifier only.

As I understand it, this comment isn't precisely accurate.  It's true
that ELF segments don't have names, but NAME is used as the name of
the newly created output section that is then placed in the unique
PT_LOAD segment.  Please fix accordingly.

This patch is OK with those changes.

Thanks.

Ian


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]