This is the mail archive of the
mailing list for the binutils project.
Re: [RFC PATCH] .bundle_align_mode
But I still haven't heard
anything in the areas in which I was hoping to receive some wisdom. That
is, the general implementation plan with the alignment frags (is there a
No. Well yes - a rewrite of gas, but that is not practical right now.
So for now, frags are the way.
the hook interface for the CPU-specific code (is md_max_size
a good name and/or signature?),
Personally I think that the name is a little too vague. When I see
"md_max_size" I think "max size of what ?". Why not make it a little
bit more feature specific, eg "md_max_bundle_length".
and optimal implementations of that hook
for x86 and ARM.
I have no problems with that.