This is the mail archive of the
mailing list for the binutils project.
Re: [PATCH] MIPS/GAS/testsuite: Fine-grained MIPS FP ISA matching
On Wed, 10 Aug 2011, Richard Sandiford wrote:
> > - run_dump_test_arches "mips5" [mips_arch_list_matching mips5]
> > + run_dump_test_arches "mips5" [mips_arch_list_matching fpisa5]
> ...please also rename mips5 to mips5-fp (as part of the same commit
> or separately, whichever you prefer).
Are you sure that is needed? Please note that the MIPS V ISA only added
FP instructions (and, for the record, to the best of my knowledge there
was no actual implementation ever). So semantically both names are
correct -- the case covers both MIPS V FP ISA additions and all the MIPS V
ISA additions at the same time.