This is the mail archive of the mailing list for the binutils project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Calling equ'd symbols in GAS

> On Thu, Jul 28, 2011 at 07:58:08PM -0500, Eduardo Cavazos wrote:

> > Any suggestions for how to implement the GAS version properly?

On Fri, 2011-07-29 at 12:41 +0930, Alan Modra wrote:

> Already fixed.

I tried with as from binutils version 2.21.1; it didn't seem to fix the

Is the fix only available in the latest cvs version? I also tried that
but make errors out:

make[2]: Entering directory `/home/dharmatech/src/binutils-cvs/binutils'
gcc -g -O2  -o sysinfo sysinfo.o syslex.o
syslex.o: In function `main':
/home/dharmatech/src/binutils-cvs/binutils/syslex.c:1: multiple
definition of `main'
sysinfo.o:/home/dharmatech/src/binutils-cvs/binutils/sysinfo.c:1: first
defined here
collect2: ld returned 1 exit status
make[2]: *** [sysinfo] Error 1
make[2]: Leaving directory `/home/dharmatech/src/binutils-cvs/binutils'
make[1]: *** [all-binutils] Error 2
make[1]: Leaving directory `/home/dharmatech/src/binutils-cvs'
make: *** [all] Error 2

This in on Ubuntu 10.10 64-bit.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]