This is the mail archive of the
mailing list for the binutils project.
Re: Should rename ELFOSABI_LINUX into ELFOSABI_GNU, and drop ELFOSABI_HURD
- From: Samuel Thibault <samuel dot thibault at ens-lyon dot org>
- To: Matt Rice <ratmice at gmail dot com>
- Cc: Thomas Schwinge <thomas at schwinge dot name>, Nick Clifton <nickc at redhat dot com>, binutils at sourceware dot org, roland at gnu dot org
- Date: Mon, 4 Jul 2011 09:15:26 +0200
- Subject: Re: Should rename ELFOSABI_LINUX into ELFOSABI_GNU, and drop ELFOSABI_HURD
- References: <20110619203224.GT27884@const.famille.thibault.fr> <4E0C4652.firstname.lastname@example.org> <email@example.com> <CACTLOFq6icHamRE3s-4d+WV_XPUx1Z6C02JYGBvRRdhb4VaAeA@mail.gmail.com>
Matt Rice, le Sun 03 Jul 2011 23:42:10 -0700, a écrit :
> On Sun, Jul 3, 2011 at 6:40 AM, Thomas Schwinge <firstname.lastname@example.org> wrote:
> > Hallo!
> > On Thu, 30 Jun 2011 10:48:02 +0100, Nick Clifton <email@example.com> wrote:
> >> ?> [ELFOSABI_GNU]
> >> Approved - please apply.
> > Applied, with the following additional changed:
> Hi, It isn't immediately obvious to me how to fix it but this patch
> broke gdb compilation,
> ELFOSABI_HURD and ELFOSABI_LINUX caused the respective i386gnu-tdep.c
> and i386-linux-tdep.c implementations to be used. Not sure what to
> replace that with, with these being the same and/or missing.
I believe it should be turned into just one case (ELFOSABI_GNU), and
then use generic_elf_osabi_sniff_abi_tag_sections, as is done for
ELFOSABI_NONE, to distinguish between LINUX and HURD.