This is the mail archive of the
mailing list for the binutils project.
Re: Should rename ELFOSABI_LINUX into ELFOSABI_GNU, and drop ELFOSABI_HURD
- From: Samuel Thibault <samuel dot thibault at ens-lyon dot org>
- To: binutils at sourceware dot org
- Date: Sat, 25 Jun 2011 01:12:49 +0200
- Subject: Re: Should rename ELFOSABI_LINUX into ELFOSABI_GNU, and drop ELFOSABI_HURD
- References: <20110619203224.GT27884@const.famille.thibault.fr>
Samuel Thibault, le Sun 19 Jun 2011 22:32:24 +0200, a écrit :
> Forwarded from http://sourceware.org/bugzilla/show_bug.cgi?id=12913
> H.J. Lu added separate ELFOSABI_LINUX and _HURD definitions, but these
> are actually meant to be the same: the dynamic linker is the same in
> both cases, from glibc, with the same "GNU" extensions.
> A recent change (http://sourceware.org/bugzilla/show_bug.cgi?id=10549)
> made this issue apparent eventually. Roland says we should simply
> rename the existing ELFOSABI_LINUX into ELFOSABI_GNU, and remove
> ELFOSABI_HURD. The attached patch does this (but keeps ELFOSABI_LINUX
> as an alias for software which may already be using it).