This is the mail archive of the
mailing list for the binutils project.
Re: Macro name and comment fixes for gas/tc-mips.c
> At Wed, 7 Jan 2004 21:48:58 +0000 (UTC), "Ian Lance Taylor" wrote:
> > I propose that we rename the macro to ISA_HAS_NONBRANCH_DELAYS to
> > avoid such confusion. This patch does that rename, and also fixes the
> > comment for this macro and for the gpr_interlocks macro.
> Looking at ISA_HAS_COPROC_DELAYS a bit more carefully, I wonder if it
> might just make more sense to fix "cop_interlocks" to include the
> appropriate ISAs (which have interlocks), and check it consistently,
> rather than checking both ISA_HAS_COPROC_DELAYS and cop_interlocks...
Yes, that is probably the next step.
As I proposed, ISA_HAS_COPROC_DELAYS should really be called
ISA_HAS_NONBRANCH_DELAYS. As such, it currently sometimes serves as a
quick test of whether to even look at the INSN_*_DELAY flags.
But the current code is definitely more confusing than necessary.
There is certainly more cleanup possible here.