binutils-cvs archive
subject index for March, 2016

This is the mail archive of the binutils-cvs@sourceware.org mailing list for the binutils project.

Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

[binutils-gdb/binutils-2_26-branch] Allow zero length archive elements

[binutils-gdb/binutils-2_26-branch] Automatic date update in version.in

[binutils-gdb/binutils-2_26-branch] Bind defined symbol locally in PIE

[binutils-gdb/binutils-2_26-branch] Check reloc against IFUNC symbol only with dynamic symbols

[binutils-gdb/binutils-2_26-branch] Fix erroneous relocations applied to absolute symbols in COFF format targets.

[binutils-gdb/binutils-2_26-branch] Fix formatting of coff-i386.c and coff-x86_64.c

[binutils-gdb/binutils-2_26-branch] ld: relax alignment requirements of compressed .debug_* section checks

[binutils-gdb/binutils-2_26-branch] PE/COFF regression in base of code and data calculation

[binutils-gdb/binutils-2_26-branch] Set BFD_DECOMPRESS to decompress debug sections

[binutils-gdb/binutils-2_26-branch] Speedup orphan placement for relocatable link

[binutils-gdb/binutils-2_26-branch] Treat common symbol in executable as definition

[binutils-gdb/binutils-2_26-branch] Update PR ld/12365 test for GCC 6

[binutils-gdb/gdb-7.11-branch] Automatic date update in version.in

[binutils-gdb] [AArch64] Create .got section if _GLOBAL_OFFSET_TABLE_ referenced

[binutils-gdb] [ARC] Add support for Quarkse opcodes.

[binutils-gdb] [ARC] Allow equ redefintion tests for ARC.

[binutils-gdb] [ARC] Allow non-instruction relocations within .text sections

[binutils-gdb] [ARC] Cleanup AUX register names.

[binutils-gdb] [ARC] Fix typo in extension instruction name.

[binutils-gdb] [ARC] Fix warn.exp test error.

[binutils-gdb] [ARM] Add feature check for ARMv8.1 AdvSIMD instructions.

[binutils-gdb] [ARM] Add support for Cortex-R8

[binutils-gdb] [ARM] Build attributes for ARMv8.1-A AdvSIMD

[binutils-gdb] [ARM] Support ARMv8.2 FP16 simd instructions

[binutils-gdb] Add -Wstack-usage to the gcc warning flags list, but only if using a sufficiently recent version of

[binutils-gdb] Add -z noreloc-overflow option to x86-64 ld

[binutils-gdb] Add const qualifiers at various places.

[binutils-gdb] Add mips and s390 build targets for gold.

[binutils-gdb] Add MIPS-64 support.

[binutils-gdb] Add missing ChangeLog entries for commit 82838

[binutils-gdb] Add missing Mips_output_data_la25_stub::do_print_to_mapfile.

[binutils-gdb] add more const qualifiers

[binutils-gdb] Add more tests for PR ld/19539

[binutils-gdb] Add new plugin hooks to support querying section alignment and size.

[binutils-gdb] Add support for STT_SPARC_REGISTER symbols.

[binutils-gdb] Add unused attribute where necessary to quiet GCC 6 warnings.

[binutils-gdb] Adjust testsuite/gas/i386/x86_64-intel.d for COFF

[binutils-gdb] Allow zero length archive elements

[binutils-gdb] Allow zero length archive elements.

[binutils-gdb] apply ChangeLog for previous commit

[binutils-gdb] arc/gas: default mach is arc700, initialised in md_begin

[binutils-gdb] arc/nps400: Add first nps400 instructions

[binutils-gdb] arc/opcodes: Use flag operand class to handle multiple flag matches

[binutils-gdb] arc: Add nps400 machine type, and assembler flag.

[binutils-gdb] arc: Remove duplicated constant in include/elf/arc.h

[binutils-gdb] arc: Remove EF_ARC_CPU_GENERIC constant.

[binutils-gdb] Attribute with DW_FORM_flag_present

[binutils-gdb] Automatic date update in version.in

[binutils-gdb] Bind defined symbol locally in PIE

[binutils-gdb] Binutils fails to build with -O0

[binutils-gdb] cast literal to char * when assigning to input_line_ptr

[binutils-gdb] cast the arg to md_assemble () to char *

[binutils-gdb] cast to char * when assigning to optarg

[binutils-gdb] Correct fr30 comment

[binutils-gdb] Created tag users/hjl/linux/release/2.26.51.0.1

[binutils-gdb] Don't create dynamic sections when relocatable

[binutils-gdb] Don't handle every plugin symbol as defined.

[binutils-gdb] Don't override definition a shared object by one in a later shared object.

[binutils-gdb] enable -Wwrite-strings for gas

[binutils-gdb] Ensure that the .rdata_pseudo_runtime_reloc sections are not discarded by gabage collection.

[binutils-gdb] Fix a ChangeLog entry

[binutils-gdb] Fix a seg-fault in the AVR linker.

[binutils-gdb] Fix checking bignum values that are being inserted into byte sized containers.

[binutils-gdb] Fix compile time warning about comparison between signed and unsigned values.

[binutils-gdb] Fix datestamps on ChangeLog entries to read 2015 instead of 2016.

[binutils-gdb] Fix failure to diagnose GOTOFF relocation to undef symbol in shared lib (i386).

[binutils-gdb] Fix generation of as.1 manual page so that it can be converted to DocBook format.

[binutils-gdb] Fix Makefile so make clean removes overlooked files.

[binutils-gdb] Fix possible failure in the AVR linker tests.

[binutils-gdb] Fix possible unbounded stack use in peXXigen.c

[binutils-gdb] Fix problem where gold cannot build .eh_frame_hdr from ld -r output.

[binutils-gdb] Fix problem where gold fails to issue an undefined symbol error during LTO.

[binutils-gdb] Fix problem with --emit-relocs for Mips-32.

[binutils-gdb] Fix shift left warning at source

[binutils-gdb] Fix some places where octet to byte conversions are needed.

[binutils-gdb] Fix the disassembly of the AArch64's OOR instruction as a MOV instruction.

[binutils-gdb] Fix tic54x regression

[binutils-gdb] Fix typo in print_insn_rl78_common function.

[binutils-gdb] Fix unbounded stack usage warning inside the SAFE_BYTE_GET macro.

[binutils-gdb] Fix undefined symbol errors introduced with previous commit.

[binutils-gdb] Fix v850 bfd arch info printable names

[binutils-gdb] fixup -Wshadow warnings on gcc-4.7

[binutils-gdb] For COFF and COFF/PE targets, skip relocations against absolute symbols.

[binutils-gdb] gas/arc: Fix test for big-endian arc

[binutils-gdb] gas: sparc: allow ASR registers in the 0..31 range in V9 and later

[binutils-gdb] get rid of K&R style args

[binutils-gdb] get_symbols() plugin API tweak to support --start-lib/--end-lib.

[binutils-gdb] Group common symbol checking together

[binutils-gdb] Handle local IFUNC symbols in shared object

[binutils-gdb] Improve COFF/PE linker garbage collection by preventing the removal of sections containing exported

[binutils-gdb] ld/testing: Fix error and warning checks in run_dump_test

[binutils-gdb] Link tmpdir/copyreloc-main.o before tmpdir/copyreloc-lib.so

[binutils-gdb] localize string returned from visium's md_atof ()

[binutils-gdb] make md_parse_option () take a const char *

[binutils-gdb] make microblaze build with -Wwrite-strings

[binutils-gdb] make more variables const

[binutils-gdb] make some variables unsigned

[binutils-gdb] make xtensa_section_rename () take const char *

[binutils-gdb] Mark the i370 target as obsolete.

[binutils-gdb] Missing TO_ADDR

[binutils-gdb] More -Wstack-usage warnings: opcodes/aarch64-*

[binutils-gdb] More cases of missing TO_ADDR in ldlang.c

[binutils-gdb] opcodes/arc/nps: Fix some operand flags

[binutils-gdb] opcodes/arc: Comment and whitespace fixes in opcode table

[binutils-gdb] opcodes: Fix date in ChangeLog entry

[binutils-gdb] PE/COFF regression in base of code and data calculation

[binutils-gdb] PR gas/19744: Thumb-1 pcrop relocations don't work on Thumb-2 targets

[binutils-gdb] PR18452, ld allows overlapping sections

[binutils-gdb] readelf printf format strings on mingw

[binutils-gdb] Refactor Output_data_reloc_base::do_write for MIPS-specific relocs.

[binutils-gdb] Regenerate bfd files.

[binutils-gdb] Regenerate bfd-in2.h

[binutils-gdb] Regenerate or1k opcodes file

[binutils-gdb] Regenerate rl78 opcodes file

[binutils-gdb] Relax assertion in BFIN linker to allow for discard GOT relocs.

[binutils-gdb] Remove bogus LONG(0) from MSP430 built in linker script.

[binutils-gdb] Remove checks for constructors that might have been eliminated by GCC.

[binutils-gdb] Remove is_n64_ data member from Mips_relobj class.

[binutils-gdb] Remove more alloca calls

[binutils-gdb] Remove spurious empty line in changelog entry.

[binutils-gdb] Remove use of alloca.

[binutils-gdb] rename flag_size_check to flag_allow_nonconst_size and make it a bool

[binutils-gdb] replace some obstack_alloc () calls with the XOBNEW wrapper

[binutils-gdb] replace some raw xmalloc / xrealloc with the XNEW* macros

[binutils-gdb] Restore v850-rh850 as a recognised v850 architecture name for backwards compatibility.

[binutils-gdb] Skip ld-elf/pr19162.d for arc target

[binutils-gdb] Skip ld-elf/pr19162.d for hppa-*-*

[binutils-gdb] sparc: reorder wr instructions in sparc_opcodes to fix diagnostics

[binutils-gdb] Speedup ELF orphan placement for relocatable link

[binutils-gdb] Speedup mmo and pe orphan placement for relocatable link

[binutils-gdb] split up cr16s md_assemble ()

[binutils-gdb] Support --as-needed in i386/x86-64 tests

[binutils-gdb] Support --as-needed in ifunc tests

[binutils-gdb] tc-i386.c: store encoded instructions in unsigned char[]

[binutils-gdb] tc-i960.c: add some casts when assigning literals to args[i]

[binutils-gdb] tc-pdp11.c: remove useless code

[binutils-gdb] tc-sparc.c: get rid of wierd usage of strchr ()

[binutils-gdb] testsuite/ChangeLog is no longer supposed to exist

[binutils-gdb] Treat common symbol in executable as definition

[binutils-gdb] Update description of AArch64 assembler directives.

[binutils-gdb] Update PR ld/12365 test for GCC 6

[binutils-gdb] Update x86 register name documentation.

[binutils-gdb] Use consistent test for .tbss sections in ldlang.c

[binutils-gdb] use do_align () directly in tc-ia64.c

[binutils-gdb] use xstrdup and friends more

[binutils-gdb] work around get_symbol_name () in sparc and ia64

[binutils-gdb] Workaround a C++ bug in GCC 4.2 in gold test

[binutils-gdb] Xfail mix_pic_and_non_pic on arm and aarch64


Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

Mail converted by MHonArc